Bug 1008873 - qemu-kvm quit when get data from rng device in guest after wakeup from S4
qemu-kvm quit when get data from rng device in guest after wakeup from S4
Status: CLOSED DUPLICATE of bug 1008273
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
:
Depends On:
Blocks: Virt-S3/S4-7.0
  Show dependency treegraph
 
Reported: 2013-09-17 05:26 EDT by Xu Han
Modified: 2015-05-24 20:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 02:32:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xu Han 2013-09-17 05:26:50 EDT
Description of problem:
qemu-kvm quit when get data from rng device in guest(RHEL6.5) after wakeup from S4.

Version-Release number of selected component (if applicable):
qemu: qemu-kvm-rhev-1.5.3-3.el7.x86_64
guest kernel: 2.6.32-419.el6.i686

How reproducible:
100%

Steps to Reproduce:
1.boot guest with rng-edg
# cat /dev/random | nc -l localhost 1024

#/usr/libexec/qemu-kvm ...
-chardev socket,host=localhost,port=1024,id=chr0 \
-object rng-egd,chardev=chr0,id=rng0 \
-device virtio-rng-pci,rng=rng0


2.do S4 on guest
#echo disk > /sys/power/state

3.wakeup guest and get data from rng device
#cat /dev/hwrng

Actual results:
after 3
hmp report 'qemu-kvm: virtio: trying to map MMIO memory' and qemu-kvm quit.

Expected results:


Additional info:
RHEL7 guest not hit this issue.
Comment 2 Amos Kong 2013-09-26 02:32:09 EDT
It's a bug of guest kernel, not qemu-kvm.

(https://bugzilla.redhat.com/show_bug.cgi?id=1008273#c7)
Comment 3 Xu Han 2013-09-26 07:19:11 EDT
Should this bug be duplicated to 1008273?  you mean they are the same issue, right?
Comment 4 Amos Kong 2013-09-26 11:29:59 EDT

*** This bug has been marked as a duplicate of bug 1008273 ***

Note You need to log in before you can comment on or make changes to this bug.