Bug 1008905 - pulp sync fails for ol_latest repo
pulp sync fails for ol_latest repo
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
Master
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 06:17 EDT by cristi falcas
Modified: 2014-11-10 13:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-10 13:55:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cristi falcas 2013-09-17 06:17:57 EDT
Description of problem:
Trying to sync the repo from http://public-yum.oracle.com/repo/OracleLinux/OL6/latest/x86_64/ fails with the following error:


[Tue Sep 17 05:18:39 2013] [error] 2013-09-17 05:18:39,410 pulp_rpm.plugins.importers.yum.sync:ERROR: sync failed
[Tue Sep 17 05:18:39 2013] [error] Traceback (most recent call last):
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 116, in run
[Tue Sep 17 05:18:39 2013] [error]     self.update_content(metadata_files)
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 242, in update_content
[Tue Sep 17 05:18:39 2013] [error]     purge.purge_unwanted_units(metadata_files, self.sync_conduit, self.call_config)
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/purge.py", line 42, in purge_unwanted_units
[Tue Sep 17 05:18:39 2013] [error]     remove_missing_errata(metadata_files, conduit)
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/purge.py", line 124, in remove_missing_errata
[Tue Sep 17 05:18:39 2013] [error]     updateinfo.PACKAGE_TAG, updateinfo.process_package_element)
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/purge.py", line 238, in get_remote_units
[Tue Sep 17 05:18:39 2013] [error]     for model in package_info_generator:
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/packages.py", line 74, in package_list_generator
[Tue Sep 17 05:18:39 2013] [error]     package_info = process_func(element)
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/updateinfo.py", line 47, in process_package_element
[Tue Sep 17 05:18:39 2013] [error]     'pkglist': map(_parse_collection, element.find('pkglist') or []),
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/updateinfo.py", line 88, in _parse_collection
[Tue Sep 17 05:18:39 2013] [error]     'packages': map(_parse_package, element.findall('package')),
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/updateinfo.py", line 111, in _parse_package
[Tue Sep 17 05:18:39 2013] [error]     'src': element.attrib['src'],
[Tue Sep 17 05:18:39 2013] [error] KeyError: 'src'
[Tue Sep 17 05:18:39 2013] [error] 2013-09-17 05:18:39,823 pulp.server.dispatch.task:ERROR: Importer indicated a failed response
[Tue Sep 17 05:18:39 2013] [error] Traceback (most recent call last):
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp/server/dispatch/task.py", line 138, in _run
[Tue Sep 17 05:18:39 2013] [error]     result = call(*args, **kwargs)
[Tue Sep 17 05:18:39 2013] [error]   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 117, in sync
[Tue Sep 17 05:18:39 2013] [error]     raise PulpExecutionException(_('Importer indicated a failed response'))
[Tue Sep 17 05:18:39 2013] [error] PulpExecutionException: Importer indicated a failed response



Definition of the repo:

Id:                  ol_latest
Display Name:        ol_latest
Description:         None
Content Unit Counts:
  Rpm:  9917
  Srpm: 3016
Notes:
Importers:
  Config:
    Feed:             http://public-yum.oracle.com/repo/OracleLinux/OL6/latest/x
                      86_64/
    Max Downloads:    5
    Remove Missing:   True
    Retain Old Count: 1
  Id:               yum_importer
  Importer Type Id: yum_importer
  Last Sync:        2013-09-17T05:18:39-04:00
  Repo Id:          ol_latest
  Scheduled Syncs:
Distributors:
  Auto Publish:        True
  Config:
    Http:         True
    Https:        False
    Relative URL: /ol_latest
  Distributor Type Id: yum_distributor
  Id:                  yum_distributor
  Last Publish:        None
  Repo Id:             ol_latest
  Scheduled Publishes:



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 cristi falcas 2013-09-18 04:02:15 EDT
it looks like this happens with the "--retain-old-count 1" switch
Comment 2 cristi falcas 2013-09-19 09:08:00 EDT
i want to amend my latest comment: sync to ol_latest fails always at the end with that exception
Comment 3 Chris Duryee 2014-11-10 08:36:51 EST
Is this still an issue? I was able to successfully sync http://public-yum.oracle.com/repo/OracleLinux/OL6/latest/x86_64/. I used 2.5.0 but I believe 2.4.3 will work as well.
Comment 4 cristi falcas 2014-11-10 13:37:09 EST
I can't test this unfortunately. We use pulp now as a forge repo only. From my point of view this can be closed as fixed. 

I will try to switch our repos to pulp again in the near future and in case of any issues I will open a new bug.
Comment 5 Chris Duryee 2014-11-10 13:55:21 EST
Sounds good. Marking BZ as closed/currentrelease.

Note You need to log in before you can comment on or make changes to this bug.