Bug 1008923 - Attempting to lock a transient node produces NPE
Attempting to lock a transient node produces NPE
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: ---
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 06:56 EDT by Horia Chiorean
Modified: 2016-02-10 03:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:59:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2047 Blocker Closed Attempting to lock a transient node produces NPE 2014-02-17 09:54:48 EST

  None (edit)
Description Horia Chiorean 2013-09-17 06:56:47 EDT
Attempting to lock a transient node via the session's lock manager before calling session.save() produces the following exception:

Caused by: java.lang.NullPointerException
at org.modeshape.jcr.cache.document.SessionNode.updateReferences(SessionNode.java:791)
at org.modeshape.jcr.cache.document.SessionNode.setProperty(SessionNode.java:766)
at org.modeshape.jcr.RepositoryLockManager.lock(RepositoryLockManager.java:209)
	... 38 more
Comment 1 JBoss JIRA Server 2013-09-18 08:58:18 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2047

According to the Javadoc from the spec methods any kind of locking on node which contains modifications should throw an {{InvalidItemStateException}}
Comment 2 JBoss JIRA Server 2013-09-18 09:03:30 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2047

According to the Javadoc from the spec methods any kind of locking on a node which contains modifications should throw an {{InvalidItemStateException}}
Comment 3 JBoss JIRA Server 2013-09-18 10:33:15 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2047

Merged into the 'master' branch. Leaving open until it is also cherry-picked to the '3.3.x-prod-ip6.0' branch.
Comment 9 JBoss JIRA Server 2013-10-24 05:19:40 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2047 to Closed
Comment 10 belong 2013-11-19 18:19:50 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 11 Filip Nguyen 2014-02-17 09:54:42 EST
Retested on GA.

Note You need to log in before you can comment on or make changes to this bug.