Bug 1008945 - Change of language to German not set in VT
Change of language to German not set in VT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 07:38 EDT by p.p.k
Modified: 2014-03-07 14:31 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 14:31:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.ifcfg (2.10 KB, text/plain)
2013-09-26 09:30 EDT, p.p.k
no flags Details
anaconda.log (46.59 KB, text/plain)
2013-09-26 09:30 EDT, p.p.k
no flags Details
anaconda_packaging.log (2.74 MB, text/plain)
2013-09-26 09:31 EDT, p.p.k
no flags Details
anaconda program.log (30.30 KB, text/plain)
2013-09-26 09:32 EDT, p.p.k
no flags Details
anaconda storage (207.08 KB, text/plain)
2013-09-26 09:33 EDT, p.p.k
no flags Details
anaconda-ks (1.46 KB, text/plain)
2013-09-26 09:33 EDT, p.p.k
no flags Details

  None (edit)
Description p.p.k 2013-09-17 07:38:20 EDT
Description of problem:

Made everything of the installation from an AMD System, Windows 7, 64 Bit, within an Oracle Virtual Box with given: 8 GB harddisk space, 3 GB RAM and 128 MB graphics space, 2 CPU cores. ISO files bound in as Virtual CD/DVD Media. (no extra tool).

During test of Fedora-Live-Desktop-x86_64-20-Alpha-3 and -Alpha-2 I have not been able to change language, esp. keyboard setting to German languange, for the local (bash) terminal. 
I have installed system-config-language, configured. Within Gnome 3 everything looked well. 
When going through, I confirmed the upcoming warning message with ja (i.e. yes):No Group named german-support exists. Do you still want to install language without proper support? 

Additional: 
- LANG is set to de_DE.UTF-8 when calling export in bash


Version-Release number of selected component (if applicable):
Fedora-Live-Desktop-x86_64-20-Alpha-2
Fedora-Live-Desktop-x86_64-20-Alpha-3

How reproducible:
Standard install, just follow every step of the installation file and try to change the system language to German.
When going through, confirm the upcoming warning message with ja (i.e. yes):No Group named german-support exists. Do you still want to install language without proper support? 

Steps to Reproduce:
1. Create a Virtual Machine within VirtualBox with above mentioned items
2. Make standard installation as described above until finished.
3. Reboot 
4. Change to a terminal by pressing Alt+F2. 
5. Check the keyboard setting by typing some characters.

Actual results:


Expected results:


Additional info:
Comment 1 Adam Williamson 2013-09-20 03:55:22 EDT
the system language setting and the keyboard layout are separate, and setting one does not change the other. To change the keyboard layout you should use the GNOME or KDE configuration tools, or (less optimally) system-config-keyboard.
Comment 2 p.p.k 2013-09-22 02:30:55 EDT
(In reply to Adam Williamson from comment #1)
> the system language setting and the keyboard layout are separate, and
> setting one does not change the other. To change the keyboard layout you
> should use the GNOME or KDE configuration tools, or (less optimally)
> system-config-keyboard.

This is what I tried to change the language for the bash screen. 

I see, in the newest Alpha RC this issue seems to be solved now.
Comment 3 p.p.k 2013-09-26 04:06:27 EDT
I did a net install today - and the bug reoccured.
Comment 4 p.p.k 2013-09-26 08:07:33 EDT
Some more information, after having chatted with kparal. 

The net install more detailled:

1. Download the net installation for i686 and burn it to CD. 
2. Walk through standard installation (LXDE) with German language and German keyboard.
3. Wait until finished.
4. Remove CD from tray. 
5. Initiate a reboot. 

--
Graphical Login screen appears...

--

6. Press [CTRL]+[ALT]+[F2] for changing to a VT (virtual terminal)

7. Check the keyboard layout - that is not German!
Comment 5 Kamil Páral 2013-09-26 08:19:11 EDT
I have done a German installation with F20 Alpha DVD x86_64 and I have a German layout in VT after install.

$ localectl 
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: de
      X11 Layout: de
     X11 Variant: nodeadkeys
Comment 6 Kamil Páral 2013-09-26 08:26:15 EDT
p.p.k: Please attach your log files, they are located in /var/log/anaconda/ and in /root/ in the installed system.
Comment 7 p.p.k 2013-09-26 09:30:14 EDT
Created attachment 803401 [details]
anaconda.ifcfg
Comment 8 p.p.k 2013-09-26 09:30:57 EDT
Created attachment 803402 [details]
anaconda.log
Comment 9 p.p.k 2013-09-26 09:31:57 EDT
Created attachment 803403 [details]
anaconda_packaging.log
Comment 10 p.p.k 2013-09-26 09:32:36 EDT
Created attachment 803404 [details]
anaconda program.log
Comment 11 p.p.k 2013-09-26 09:33:04 EDT
Created attachment 803405 [details]
anaconda storage
Comment 12 p.p.k 2013-09-26 09:33:31 EDT
Created attachment 803406 [details]
anaconda-ks
Comment 13 p.p.k 2013-09-26 09:35:49 EDT
After the fifth (or so, didn't count..) the VT keyboard layout is German.

Don't know what that is.. 

Obviously ALPHA.

Note You need to log in before you can comment on or make changes to this bug.