Bug 100900 - anaconda thinks Intel D875PBZ is a multiprocessor board
Summary: anaconda thinks Intel D875PBZ is a multiprocessor board
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-26 22:09 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 15:57:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/hwconf from RedHat 9 system with D875PBZ board (4.35 KB, text/plain)
2003-07-26 22:09 UTC, Jay Berkenbilt
no flags Details

Description Jay Berkenbilt 2003-07-26 22:09:12 UTC
Description of problem:

After installing on an Intel D875PBZ board, anaconda has installed the SMP
kernel in addition to the uniprocessor kernel.  This is a uniprocessor board.

Version-Release number of selected component (if applicable):

9.0.93

How reproducible:

always

Steps to Reproduce:
1. Install SEVERN on a system that has an Intel D875PBZ board.
    
Actual results:

Both the uniprocessor and SMP kernels are installed.

Expected results:

Only the uniprocessor kernel should be installed.

Additional info:

Here is the link to information about this board on Intel's site:

http://www.intel.com/design/motherbd/bz/index.htm?iid=ipp_browse+motherbd_d875pbz

This problem happened with RedHat 9 as well, but I didn't report it since the
board came out after RedHat 9 had already been released.  I don't have access to
a SEVERN machine with this board, but I am attaching the /etc/sysconfig/hwconf
file from a machine with this board that is running RedHat 9 in case that
provides any useful information.  Please let me know if there is any other
information that would be useful.

Comment 1 Jay Berkenbilt 2003-07-26 22:09:59 UTC
Created attachment 93166 [details]
/etc/sysconfig/hwconf from RedHat 9 system with D875PBZ board

Comment 2 Jeremy Katz 2003-07-27 03:12:04 UTC
Doesn't this have a processor which utilizes hyperthreading, though?  If so,
that's why.

Comment 3 Jay Berkenbilt 2003-07-27 15:13:44 UTC
Yes, it does.  Is this correct behavior?  Should I be using an SMP kernel on a
uniprocessor machine with hyperthreading, or is the install software incorrectly
using this as an indicator?

Comment 4 Jeremy Katz 2003-07-28 15:57:22 UTC
Then the SMP kernel is correct.  Hyperthreading provides both a physical and
logical CPU to the OS -- to take advantage of both, you have to use an SMP kernel.


Note You need to log in before you can comment on or make changes to this bug.