Bug 1009002 - havana aio packstack install fails w/ glance issues
havana aio packstack install fails w/ glance issues
Status: CLOSED DUPLICATE of bug 1006783
Product: RDO
Classification: Community
Component: openstack-glance (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 09:22 EDT by wes hayutin
Modified: 2016-04-26 18:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 11:43:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glance logs (3.79 KB, text/plain)
2013-09-17 09:22 EDT, wes hayutin
no flags Details
glance api log (1.90 KB, text/plain)
2013-09-17 09:38 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2013-09-17 09:22:15 EDT
Created attachment 798818 [details]
glance logs

Description of problem:
192.168.122.169_ceilometer.pp :         [ DONE ]
                        [ ERROR ]

ERROR : Error during puppet run : Error: Could not prefetch glance_image provider 'glance': Execution of '/usr/bin/glance -T services -I glance -K redhat -N http://192.168.122.169:35357/v2.0/ index' returned 1: Error communicating with http://192.168.122.169:9292 [Errno 111] Connection refused


See attached log file
Comment 1 wes hayutin 2013-09-17 09:31:08 EDT
[root@rhel6 ~]# /usr/bin/glance -T services -I glance -K redhat -N http://192.168.122.169:35357/v2.0/ index
ID                                   Name                           Disk Format          Container Format     Size          
------------------------------------ ------------------------------ -------------------- -------------------- --------------
Error communicating with http://192.168.122.169:9292 [Errno 111] Connection refused
[root@rhel6 ~]#
Comment 2 wes hayutin 2013-09-17 09:32:19 EDT
[root@rhel6 ~(keystone_admin)]# /etc/init.d/openstack-glance-api status
openstack-glance-api dead but pid file exists
[root@rhel6 ~(keystone_admin)]# /etc/init.d/openstack-glance-api start
Starting openstack-glance-api:                             [  OK  ]
[root@rhel6 ~(keystone_admin)]# /etc/init.d/openstack-glance-api status
openstack-glance-api (pid  6614) is running...
[root@rhel6 ~(keystone_admin)]# /usr/bin/glance -T services -I glance -K redhat -N http://192.168.122.169:35357/v2.0/ index
ID                                   Name                           Disk Format          Container Format     Size          
------------------------------------ ------------------------------ -------------------- -------------------- --------------
[root@rhel6 ~(keystone_admin)]#
Comment 3 wes hayutin 2013-09-17 09:38:38 EDT
Created attachment 798822 [details]
glance api log
Comment 4 wes hayutin 2013-09-17 11:43:11 EDT

*** This bug has been marked as a duplicate of bug 1006783 ***

Note You need to log in before you can comment on or make changes to this bug.