Bug 100902 - kickstart mode for package selection only
kickstart mode for package selection only
Status: CLOSED DEFERRED
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 18:17 EDT by Jay Berkenbilt
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 11:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2003-07-26 18:17:34 EDT
I wish there were a way in Kickstart to specify only package selection (along
with "upgrade" or "install" probably) and to have everything else be interactive
as if there were no kickstart configuration file.  This is almost achieved by
removing everything but "install" and "%packages" from the ks.cfg file, but
there are a few exceptions.  For example, if there are no "network" statements
in the ks.cfg file, the install assumes that there are no network interfaces
instead of bringing the user to the screen that allows configuration of detected
network interfaces.

I never really considered this to be much of an issue before, but since the
ability to select individual packages has now disappeared, this has become a
fairly significant issue for me.  For example, my login shell is zsh, and I use
sawfish as my window manager.  (I used sawfish since before it was RedHat's
default and continue to use it now that it is no longer RedHat's default.)  I
also use pcre-devel a lot in my work.  Without either the package selection
option or this request, it is no longer possible for me to have a machine that I
can log into without having to do a lot of manual configuration.  This is not
really a big deal, but I make this suggestion just in case it ends up being easy
to implement.

An executive summary, I suppose, would be that the ks.cfg file should
distinguish between having none of something and selecting something interactively.
Comment 1 Jeremy Katz 2003-07-26 23:13:17 EDT
Unfortunately, doing this would break behavior for legacy kickstart configs :/

Deferring until the day I completely change the ks.cfg syntax (but will keep it
in mind as directives get changed in incompatible ways for other reasons)
Comment 2 Jay Berkenbilt 2003-07-27 11:16:10 EDT
Deferring seems quite appropriate, but I'd point out that it could be done in a
backward-compatible fashion by having a new syntax for interactive rather than
interpreting missing this way, for example: network interactive....
Comment 3 Jay Berkenbilt 2003-07-27 11:17:02 EDT
Reopening so I know this is seen.  Actually, I hit commit by mistake.  Anyway,
reclose when you've seen my additional comment.....
Comment 4 Jeremy Katz 2003-07-28 11:58:56 EDT
Which then adds more crufty junk, which I'd rather avoid (kickstart is already
fragile enough internally).  

Note You need to log in before you can comment on or make changes to this bug.