Bug 1009035 - spacewalk-splice-tool does not map all arches correctly
spacewalk-splice-tool does not map all arches correctly
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-09-17 10:22 EDT by Chris Duryee
Modified: 2013-10-01 07:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:26:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2013-09-17 10:22:41 EDT
Description of problem: Some architectures are not mapped correctly by spacewalk-splice-tool into something that candlepin can understand.

Specifically, "athlon" needs to get converted to i386, and both "ppc64pseries" and "ppc64iseries" need to get converted to "ppc64"


Version-Release number of selected component (if applicable): 0.45


How reproducible: every time


Steps to Reproduce:
1. find a machine that reports as athlon, ppc64pseries or ppc64iseries
2. install RHEL 4, register it to sat 5.6
3. run spacewalk-splice-tool, attempt to bind an i386 or ppc64 subscription

Actual results:

autoattach will fail, and manual binding will result in a "yellow" system

Expected results:

system should be "green"

Additional info: The system can't become green because candlepin does not realize that the system arches reported by spacewalk-splice-tool are the same as the arches it knows about.
Comment 2 Chris Duryee 2013-09-17 14:16:54 EDT
65cb091 spacewalk-splice-tool 0.46
Comment 3 Vitaly Kuznetsov 2013-09-19 07:51:15 EDT
Verified with Snapshot 7:
EM64T => x86_64
athlon => i386
ppc64pseries => ppc64
ppc64iseries => ppc64
Comment 5 errata-xmlrpc 2013-10-01 07:26:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.