Bug 1009052 - prestarted VMs in a pool do not use sysprep file
prestarted VMs in a pool do not use sysprep file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
urgent Severity high
: ---
: 3.2.4
Assigned To: Tomas Jelinek
Ilanit Stein
virt
: Reopened, ZStream
Depends On: 1006659
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 10:51 EDT by rhev-integ
Modified: 2014-01-14 19:17 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Virtual machines created as part of a prestarted pool did not use the appropriate sysprep file, so they did not acquire the settings specified by the sysprep process. This has now been fixed, so virtual machines in prestarted pools are sysprepped as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 14:44:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 484393 None None None Never

  None (edit)
Description rhev-integ 2013-09-17 10:51:46 EDT
+++ This bug is a RHEV-M zstream clone. The original bug is: +++
+++   https://bugzilla.redhat.com/show_bug.cgi?id=1006659. +++

======================================================================



----------------------------------------------------------------------
Following comment by byount@redhat.com on September 11 at 04:25:22, 2013

Description of problem:
When a VM is spun up as part of a "prestarted pool", it does not properly use the appropriate sysprep file and thus the VM does not join the Active Directory domain.

Version-Release number of selected component (if applicable):
3.2.2

Steps to Reproduce:
1. Create a pool
2. Select a Windows 7 template
3. Enable a number of prestarted virtual machines

Actual results:
The resulting VMs are not sysprepped

Expected results:
The VM should sysprep properly

----------------------------------------------------------------------
Following comment by byount@redhat.com on September 11 at 04:27:27, 2013

This was reported by the FBI/CJIS
   Account # 1354910
   Strategic

----------------------------------------------------------------------
Following comment by byount@redhat.com on September 12 at 01:49:42, 2013

I tested this on my own environment which isn't connected to an AD domain but the results of the test should still be the same. I am merely observing if the A:\sysprep.inf file is presented to the guest when I log in:

   1. created a pool of 5 Windows 7 VMs
   2. set the prestart number to 2
   3. logged into the User Portal
   4. Checked out a VM from that pool
   5. Connected to the guest
   6. Filled out the Windows Setup questions that you see when there is no sysprep file present
   7. The VM did not reboot; it logged me in automatically
   8. No A:\sysprep.inf file exists

Are the customer and/or myself doing something wrong here?

----------------------------------------------------------------------
Following comment by iheim@redhat.com on September 16 at 05:55:37, 2013

when setting needinfo, please always set it on someone specific

----------------------------------------------------------------------
Following comment by tjelinek@redhat.com on September 16 at 08:44:32, 2013

This works on upstream. It has been fixed by 37952bef3fdafa6796b402a4c9a2313a0904f1f8 but it is partially a refactor and also strongly depends on the cloud init integration so there is no simple way to backport it. To fix this on the 3.2.2 it would require a downstream only patch (most probably a one line fix in VmPoolMonitor).

----------------------------------------------------------------------
Following comment by michal.skrivanek@redhat.com on September 16 at 09:00:37, 2013

closing in 3.3 as fixed

----------------------------------------------------------------------
Following comment by jduncan@redhat.com on September 16 at 13:02:01, 2013

Michael,

Looking for some clarification here. The 3.2z flag was set, and there was talk of a one-line backport into 3.2. 

Is that possible? Is it planned?

Thanks.

----------------------------------------------------------------------
Following comment by michal.skrivanek@redhat.com on September 16 at 13:41:24, 2013

yeah, once QA and PM acks the bug(this one) it will be cloned & fixed
I can't clone it without PM and QA accepting the proposal, though.

----------------------------------------------------------------------
Following comment by jduncan@redhat.com on September 16 at 13:46:12, 2013

Is there any way we can get the PM/QA acks so this can move forward?

This issue is affecting a large production cluster at a large public sector customer (CJIS, mentioned above), who use RHEV for their VDI solution.

Their environment was just upgraded to 3.2, and the next upgrade window is a long ways off. If we could get this into 3.2z it would be very helpful.

Thanks,

Jamie Duncan

----------------------------------------------------------------------
Following comment by michal.skrivanek@redhat.com on September 16 at 15:57:45, 2013

should be tested...

----------------------------------------------------------------------
Following comment by byount@redhat.com on September 17 at 02:13:43, 2013

Michal, do you happen to know when this functionality was broken? Was it in the 3.2 branch? I know my former customer, State Street, loves the prestarted pool functionality in 3.1 and we're about to do a major upgrade to 3.2. If this feature is broken in 3.2, they will want to know prior to upgrade.

----------------------------------------------------------------------
Following comment by michal.skrivanek@redhat.com on September 17 at 10:22:48, 2013

Likely it is indeed broken in current latest 3.2.z, the request for 3.2.z fix is valid
Comment 1 wiley crider 2013-09-20 13:34:24 EDT
IS there an ETA for the inclusion in the 3.2.z?
Comment 2 Itamar Heim 2013-09-22 05:32:45 EDT
(In reply to wiley crider from comment #1)
> IS there an ETA for the inclusion in the 3.2.z?

please always set needinfo on someone specific.
the bug is modified with a target release of 3.2.4. for anything earlier, please discuss with GSS wrt a hotfix.
Comment 4 Ilanit Stein 2013-10-17 02:34:23 EDT
checked on sf21.1, by the following flow from original 3.3 bug 1006659:
1) Added ldap server and added user from server to rhevm
2) Created vm with windows 7(operating system windows 7 64-bit) on domain of ldap server
3) Vm sealed and created template from vm
4) Created vms pool with 5 vms from template
5) Set number of prerestarted vms to two
6) Wait until os is up on prerestarted vm
7) No welcome screen, see login screen in ldap domain
8) Entered to OS with user and password from that added to rhevm from ldap domain
9) Also floppy disk with sysprep.inf exist

There was some problem with the sysprep, for which the prestarted vms where not installed with windows automatically, but I checked vdsm.log, and sew the sysprep.inf file sent in vmcreate command (VM run)
Comment 7 errata-xmlrpc 2013-10-25 14:44:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1468.html

Note You need to log in before you can comment on or make changes to this bug.