Bug 1009078 - Pulp 2.2 is unable to sync RHEL repository with a proxy server
Pulp 2.2 is unable to sync RHEL repository with a proxy server
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
2.2
x86_64 Linux
unspecified Severity high
: ---
: 2.3.0
Assigned To: Jason Connor
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 11:28 EDT by benjamin.papillon
Modified: 2014-03-30 21:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:31:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benjamin.papillon 2013-09-17 11:28:46 EDT
Description of problem:
  Pulp 2.2. downloader is unable to sync to RHEL6 repository when a proxy is present

Version-Release number of selected component (if applicable):
 Pulp 2.2 is affected
 Pulp 2.1 worked fine

How reproducible: Always

Steps to Reproduce:
1. Create repository RHEL6 with certificates to authenticate to RHN + proxy informations
2. Sync repository


Actual results: Sync fail
(I)root@frhdstdrezr01:~# pulp-admin rpm repo sync run --repo-id RHEL6-x86_64-update
+----------------------------------------------------------------------+
             Synchronizing Repository [RHEL6-x86_64-update]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.
Downloading metadata...
[/]
... failed
[Errno 113] No route to host
(I)root@frhdstdrezr01:~#

pulp log file :


2013-09-17 17:26:39,440 urllib3.connectionpool:INFO: Starting new HTTPS connection (1): cdn.redhat.com
2013-09-17 17:26:42,487 nectar.downloaders.threaded:ERROR: [Errno 113] No route to host
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 160, in _fetch
    response = session.get(request.url, headers=headers)
  File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 310, in get
    return self.request('GET', url, **kwargs)
  File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 279, in request
    resp = self.send(prep, stream=stream, timeout=timeout, verify=verify, cert=cert, proxies=proxies)
  File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 374, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.6/site-packages/requests/adapters.py", line 206, in send
    raise ConnectionError(sockerr)
ConnectionError: [Errno 113] No route to host
2013-09-17 17:26:42,489 pulp_rpm.plugins.importers.yum.sync:ERROR: sync failed
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 109, in run
    metadata_files = self.get_metadata()
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 194, in get_metadata
    raise FailedException(str(e))
FailedException: [Errno 113] No route to host
2013-09-17 17:26:42,519 pulp.server.dispatch.task:ERROR: Importer indicated a failed response
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/dispatch/task.py", line 138, in _run
    result = call(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 117, in sync
    raise PulpExecutionException(_('Importer indicated a failed response'))
PulpExecutionException: Importer indicated a failed response
2013-09-17 17:26:42,520 pulp.server.dispatch.task:INFO: FAILURE: Task a5987e98-46a9-4613-a171-151d34e609fe: CallRequest: RepoSyncManager.sync(u'RHEL6-x86_64-update', sync_config_override=None)



Expected results: Sync succeed


Additional info:
Comment 1 Jason Connor 2013-09-19 17:52:14 EDT
PR for this:
https://github.com/pulp/nectar/pull/10
Comment 2 benjamin.papillon 2013-09-23 10:22:12 EDT
I tried the last build (pulp-server-2.3.0-0.14.alpha.el6.noarch) and the diff in the pull req. seems to be in. So I tried again :)

Sync'ing RHEL6 repo failed with the following message:
(I)root@frhdstdrezr01:pulp# pulp-admin rpm repo sync run --repo-id RHEL6-x86_64 +----------------------------------------------------------------------+
                Synchronizing Repository [RHEL6-x86_64]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[\]
... failed

Not Implemented

(I)root@frhdstdrezr01:pulp#

If we look at the squid log file, we can find that nectar use GET to request an https URL. Usually it is a CONNECT method to access SSL content.
Sep 23 16:12:53 rm-ns00000-ri01 (squid): 10.10.10.10 - - [23/Sep/2013:16:12:53 +0200] "GET https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os/repodata/repomd.xml HTTP/0.0" 501 3923 "-" "-" NONE:NONE


Please tell me if you need any additionnal informations.

Regards
Comment 3 Jeff Ortel 2013-10-02 09:30:51 EDT
build: 2.3.0-0.17.beta
Comment 4 benjamin.papillon 2013-10-04 05:46:32 EDT
I tried the new 2.3-0.17 build, same error as comment #2.

(I)root@frhdstdrezr01:~# pulp-admin rpm repo sync run --repo-id RHEL5-x86_64
+----------------------------------------------------------------------+
                Synchronizing Repository [RHEL5-x86_64]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[\]
... failed

Not Implemented

(I)root@frhdstdrezr01:~#

Extract from rpm repo list --details :
Id:                  RHEL5-x86_64
Importers:
  Config:
    Feed:                https://cdn.redhat.com/content/dist/rhel/server/5/5Serv
                         er/x86_64/os
    Feed SSL Configured: True
    Proxy Host:          http://10.9.8.7
    Proxy Password:      none
    Proxy Port:          8080
    Proxy Username:      none
[...]
Comment 5 Preethi Thomas 2013-10-04 08:44:21 EDT
fails-qa
This would still be a issue tracked here

https://bugzilla.redhat.com/show_bug.cgi?id=1014368
Comment 6 Jeff Ortel 2013-10-11 11:25:57 EDT
build: 2.3.0-0.18.beta
Comment 7 Preethi Thomas 2013-10-14 09:27:38 EDT
verified. More info in this bz

https://bugzilla.redhat.com/show_bug.cgi?id=1014368
Comment 8 benjamin.papillon 2013-10-17 09:57:33 EDT
I confirm that at least version 2.3.0-22 did fix the problem
Comment 9 Preethi Thomas 2013-12-09 09:31:16 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.