Bug 1009098 - Need ccs cluster.rng synched up with latest resource agents options
Summary: Need ccs cluster.rng synched up with latest resource agents options
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 711586
TreeView+ depends on / blocked
 
Reported: 2013-09-17 16:49 UTC by Chris Feist
Modified: 2018-12-04 15:53 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 21:53:14 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1673 normal SHIPPED_LIVE ricci bug fix and enhancement update 2013-11-20 21:52:49 UTC
Red Hat Bugzilla 725722 None None None Never
Red Hat Bugzilla 878108 None None None Never
Red Hat Bugzilla 1055424 None None None Never

Internal Trackers: 725722 878108 1055424

Description Chris Feist 2013-09-17 16:49:01 UTC
Description of problem:
ricci/ccs needs the latest cluster.rng to properly display cluster options

How reproducible:
Always

Steps to Reproduce:
1. ccs -h localhost --lsresourceopts named | grep transf
 or
2. diff /usr/share/ccs/cluster.rng /var/lib/cluster/cluster.rng

Actual results:
1. Returns nothing
2. Returns lots of stuff

Expected results:
1. Should return transfer-source information
2. Should return nothing

Comment 1 David Vossel 2013-09-17 16:59:35 UTC
(In reply to Chris Feist from comment #0)
> Description of problem:
> ricci/ccs needs the latest cluster.rng to properly display cluster options
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. ccs -h localhost --lsresourceopts named | grep transf

The name of the option is actually update_source.

ccs -h localhost --lsresourceopts named | grep update_source

>  or
> 2. diff /usr/share/ccs/cluster.rng /var/lib/cluster/cluster.rng

There are probably other differences besides the one in the named agent.  Doing a diff would be the best option.

Comment 10 Chris Feist 2013-09-19 22:50:16 UTC
Make sure latest fence-agents, resource-agents, pacemaker, sanlock & fence-virt packages are installed.

Before fix:
[root@ask-02 test]# rpm -q ccs
ccs-0.16.2-66.el6.x86_64
[root@ask-02 test]# diff /usr/share/ccs/cluster.rng /var/lib/cluster/cluster.rng 
... lots of output ...

After fix:
[root@ask-02 test]# rpm -q ccs
ccs-0.16.2-67.el6.x86_64
[root@ask-02 test]# diff /usr/share/ccs/cluster.rng /var/lib/cluster/cluster.rng
[root@ask-02 test]# 


Also:
[root@ask-02 test]# grep update_source /usr/share/ccs/cluster.rng
          <attribute name="update_source" rha:description="Use cluster ip as source."/>
[root@ask-02 test]#

Comment 14 errata-xmlrpc 2013-11-21 21:53:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1673.html


Note You need to log in before you can comment on or make changes to this bug.