Bug 1009124 - Metrics list from previous resource cached when navigating Monitor Sub Tabs
Metrics list from previous resource cached when navigating Monitor Sub Tabs
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity urgent
: ER02
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On: 1009089
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 14:14 EDT by Heiko W. Rupp
Modified: 2014-01-02 15:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1009089
Environment:
Last Closed: 2014-01-02 15:37:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpu_metrics (148.50 KB, image/png)
2013-09-24 07:51 EDT, Armine Hovsepyan
no flags Details
cpu-schedules (175.44 KB, image/png)
2013-09-24 07:51 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Heiko W. Rupp 2013-09-17 14:14:52 EDT
+++ This bug was initially created as a clone of Bug #1009089 +++

Description of problem:
This one is a little but tricky to reproduce. But is one of those bugs you would run into with ad-hoc use.


How reproducible:
Always if the proper sequence of steps is performed.


Steps to Reproduce:
1. In the resource tree click on EAP RHQ Server
2. Select the monitoring tab and the Schedules sub tab
3. Now change resources, say to CPU 0
4. Now change to the Monitoring tab and change to Metrics sub tab

Actual results:
Metrics are shown from the previous resource and not the current resource.



The new metrics view is caching the changes between sub tab navigation (Schedules to Metrics) as it now is stateful to remember the opened graphs in the expandable table.

[jsanda actually found this bug]
Comment 1 Mike Thompson 2013-09-17 19:44:57 EDT
committed to master: 1e23623

Move the stateful momento containing open chart rows out to the ResourceDetailView instead of at the MetricsTableView which can then be created and destroyed like the other stateless views and state momento passed into the View to restore previous (opened rows) state.

This is on master and will become part of JON 3.2.0 as we have not branched off of  master yet.
Comment 2 Armine Hovsepyan 2013-09-24 07:50:32 EDT
the issue is still visible in: Version: 3.2.0.ER1  Build Number: 54dd29c:464a643
Comment 3 Armine Hovsepyan 2013-09-24 07:51:01 EDT
Created attachment 802194 [details]
cpu_metrics
Comment 4 Armine Hovsepyan 2013-09-24 07:51:21 EDT
Created attachment 802195 [details]
cpu-schedules
Comment 5 Mike Thompson 2013-09-24 11:12:07 EDT
I just confirmed in master and it is fixed. Looks like this went into ER02 and not ER01 please check again on ER02.
Comment 6 Armine Hovsepyan 2013-10-02 07:09:17 EDT
verified with ER02.

eap has enabled schedules thus corresponding metrics -> http://d.pr/i/Z4kH
cpu doesn't have enabled scheduled -> http://d.pr/i/HieB
thus cpu doesn't have metrics -> http://d.pr/i/HYc1

Note You need to log in before you can comment on or make changes to this bug.