This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1009127 - Red Hat products and repos cannot be added to content view definitions, don't show up in selector
Red Hat products and repos cannot be added to content view definitions, don't...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: David Davis
Garik Khachikyan
: Triaged
Depends On:
Blocks: 1008020
  Show dependency treegraph
 
Reported: 2013-09-17 14:21 EDT by David Davis
Modified: 2015-01-04 17:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:10:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Davis 2013-09-17 14:21:14 EDT
Description of problem:

When trying to add a product or repo to a content view definition, they no longer show up in the selector.


Version-Release number of selected component (if applicable):

Nightly


How reproducible:

Always


Steps to Reproduce:
1. Upload a manifest, enable some repos, sync the repos.
2. Go to a content view definition edit page, the content tab.
3. Note that the products and repos don't show up, cannot be added to the definition, etc.


Actual results:

Can't add RH products/repos to a definition.


Expected results:

Should be able to add products/repos from RH to a definition.


Additional info:
Comment 1 RHEL Product and Program Management 2013-09-17 14:25:41 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 David Davis 2013-09-17 17:10:18 EDT
https://github.com/Katello/katello/pull/2981
Comment 4 David Davis 2013-09-17 17:11:00 EDT
Opened a separate task on github to further refactor the code:

https://github.com/Katello/katello/issues/2982
Comment 5 Corey Welton 2013-09-17 17:26:52 EDT
I am not seeing this in the latest puddle, oddly enough, but will ACK and retest once it is onqa
Comment 7 David Davis 2013-09-18 14:50:45 EDT
https://github.com/Katello/katello/pull/2981
Comment 8 Corey Welton 2013-09-19 14:11:36 EDT
This does show up in the newest, latest and greatest(?) snap, however. :P
Comment 9 David Davis 2013-09-19 14:11:53 EDT
61ebd333fc4721d5908050b539d80521d41f95af

1009127: Change scope for editable_products
Now that Red Hat products can no longer be editable, we should use readable to
determine if a product can be attached to a content view definition.
Comment 12 Garik Khachikyan 2013-10-22 07:23:54 EDT
# VERIFIED

works just fine now on the version of:
===
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 13 Bryan Kearney 2014-04-24 13:10:03 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 14 Bryan Kearney 2014-04-24 13:11:23 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.