Bug 1009129 - puppet repo bind fails from consumer
puppet repo bind fails from consumer
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: puppet-support (Show other bugs)
Master
Unspecified Unspecified
medium Severity unspecified
: ---
: 2.3.0
Assigned To: Jeff Ortel
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 14:26 EDT by Preethi Thomas
Modified: 2013-12-09 09:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:29:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-09-17 14:26:40 EDT
Description of problem:
Trying to bind a puppet repo to consumer ends with task failed

Version-Release number of selected component (if applicable):
[root@pulp-v2-client ~]# rpm -qa pulp-consumer-client
pulp-consumer-client-2.3.0-0.12.alpha.el6.noarch
[root@pulp-v2-client ~]# 


How reproducible:


Steps to Reproduce:
[root@pulp-v2-client ~]# pulp-consumer -u admin -p admin puppet bind --repo-id puppet-repo
This command may be exited via ctrl+c without affecting the request.

-- Updating Pulp Server --
[-]
Waiting to begin...

[-]
Running...

Task Succeeded


-- Notifying the Consumer --
[-]
Waiting to begin...

[-]
Running...

Task Failed

[u"AuthenticationFailure: Error in sasl_client_start (-1) SASL(-1): generic
failure: GSSAPI Error: Unspecified GSS failure.  Minor code may provide more
information (Credentials cache file '/tmp/krb5cc_48' not found)\n"]

Error in sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error:
Unspecified GSS failure.  Minor code may provide more information (Credentials
cache file '/tmp/krb5cc_48' not found)

[root@pulp-v2-client ~]# 

Actual results:


Expected results:


Additional info:
Comment 1 Preethi Thomas 2013-09-17 14:35:43 EDT
[root@pulp-v2-server ~]# pulp-admin  puppet consumer install run --consumer-id pulp-client -u puppetlabs/stdlib/
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...


Install Failed

Error in sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error:
Unspecified GSS failure.  Minor code may provide more information (Credentials
cache file '/tmp/krb5cc_48' not found)

[root@pulp-v2-server ~]#
Comment 2 Jeff Ortel 2013-10-02 13:02:22 EDT
Works for me:

[root@pulp1 ~]# pulp-admin puppet consumer bind --repo-id=forge --consumer-id=pulp3
This command may be exited via ctrl+c without affecting the request.

-- Updating Pulp Server --
[-]
Waiting to begin...

[-]
Running...

Task Succeeded


-- Notifying the Consumer --
[-]
Waiting to begin...

[\]
Running...

Task Succeeded


[root@pulp2 ~]# pulp-consumer -u admin -p admin puppet bind --repo-id=forge
This command may be exited via ctrl+c without affecting the request.

-- Updating Pulp Server --
[-]
Waiting to begin...

[-]
Running...

Task Succeeded


-- Notifying the Consumer --
[-]
Waiting to begin...

[-]
Running...

Task Succeeded



Please retest.
Comment 3 Preethi Thomas 2013-10-04 10:03:00 EDT
[root@pulp-v2-client ~]# rpm -qa pulp-consumer-client
pulp-consumer-client-2.3.0-0.17.beta.el6.noarch
[root@pulp-v2-client ~]# 


[root@pulp-v2-client ~]# pulp-consumer -u admin -p admin puppet bind --repo-id puppet-repo
This command may be exited via ctrl+c without affecting the request.

-- Updating Pulp Server --
[-]
Waiting to begin...

[-]
Running...

Task Succeeded


-- Notifying the Consumer --
[-]
Waiting to begin...

[-]
Running...

Task Succeeded


[root@pulp-v2-client ~]# pulp-consumer puppet repos
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

Id:                  puppet-repo
Display Name:        puppet-repo
Description:         None
Content Unit Counts: 
  Puppet Module: 38
Notes:               


[root@pulp-v2-client ~]#
Comment 4 Preethi Thomas 2013-12-09 09:29:56 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.