This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1009132 - updates-plugin-WARNING **: failed to download: The backend exited unexpectedly.
updates-plugin-WARNING **: failed to download: The backend exited unexpectedly.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
AcceptedBlocker https://fedoraproject...
: CommonBugs
Depends On:
Blocks: F20AlphaFreezeException F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-17 14:38 EDT by Petr Schindler
Modified: 2013-10-13 15:53 EDT (History)
12 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-3.10.0-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-13 15:53:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-settings-daemon logs (8.57 KB, text/x-log)
2013-09-17 14:38 EDT, Petr Schindler
no flags Details
output from packagekitd (201.23 KB, text/x-log)
2013-09-18 13:22 EDT, Petr Schindler
no flags Details
output from journalctl -a (1.12 MB, text/x-log)
2013-09-18 13:23 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2013-09-17 14:38:12 EDT
Created attachment 798937 [details]
gnome-settings-daemon logs

Description of problem:
Updates aren't installed when I try to update with gnome-software. System is rebooted twice, but no updates are installed.

In logs I can see these things:
failed to read: Feailed to open file '/var/lib/PackageKit/prepared-update': No such file or directory

  updates-plugin-WARNING **: failed to download: The backend exited unexpectedly. This is a serious error as the spawned backend did not complete the pending transaction.

You can find gnome-settings-daemon logs in attachment. 


Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.9.91.1-2.fc20
gnome-software-3.9.3-2.fc20

How reproducible:
always

Steps to Reproduce:
1. run gnome-software
2. go to updates
3. click on 'restart & install'
4. restart

Actual results:
No updates are installed.

Expected results:
Updates are installed

Additional info:
Comment 1 Petr Schindler 2013-09-17 15:02:39 EDT
This update method is meant to be default so I propose it as freeze exception. It violates this criterion: "The installed system must be able to download and install updates with yum and with the default graphical package manager in all release-blocking desktops."

I propose it as FE because there is another possibility how to update with gui - PK which works and now is equivalent to gnome-software.
Comment 2 Richard Hughes 2013-09-18 12:32:35 EDT
Can you please do (as root):

killall packagekitd
sudo /usr/libexec/packagekitd --backend=yum --disable-timer --verbose

Then try to reproduce the bug. Hopefully a python backtrace should appear in the terminal. If so, that allows me to find the bug. Thanks.
Comment 3 Petr Schindler 2013-09-18 13:22:53 EDT
Created attachment 799513 [details]
output from packagekitd

This is what I get when I run suggested commands.
Comment 4 Petr Schindler 2013-09-18 13:23:37 EDT
Created attachment 799514 [details]
output from journalctl -a
Comment 5 Mike Ruckman 2013-09-18 15:21:39 EDT
Discussed in 2013-09-18 blocker review meeting [1]. While graphical updates are not required for alpha, fixing it would be a good move. A tested fix would be considered past freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-18/
Comment 6 Mike Ruckman 2013-09-25 13:49:32 EDT
Discussed in 2013-09-18 blocker review meeting [1]. AcceptedBlocker - Violates the following F20 beta criterion for graphical updates on a gnome install: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria
Comment 7 Fedora Update System 2013-10-11 13:06:41 EDT
gnome-settings-daemon-3.10.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.10.0-3.fc20
Comment 8 Fedora Update System 2013-10-11 22:26:40 EDT
Package gnome-settings-daemon-3.10.0-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.10.0-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18939/gnome-settings-daemon-3.10.0-3.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-10-13 15:53:05 EDT
gnome-settings-daemon-3.10.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.