Bug 1009164 - Referencing wrong activemq connector in the docs
Referencing wrong activemq connector in the docs
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
1.2.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Bilhar
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 17:09 EDT by Juergen Hoffmann
Modified: 2017-03-08 12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 19:43:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Hoffmann 2013-09-17 17:09:45 EDT
Description of problem:
in the deployment guide section 5.8.4.4.3. Configuring MCollective for Redundant ActiveMQ Services the docs tell the reader to configure them like

connector = stomp 
plugin.stomp.pool.size = 3
plugin.stomp.pool.host1=activemq1.example.com
plugin.stomp.pool.port1=61613
plugin.stomp.pool.user1=mcollective
plugin.stomp.pool.password1=marionette
plugin.stomp.pool.host2=activemq2.example.com
plugin.stomp.pool.port2=61613
plugin.stomp.pool.user2=mcollective
plugin.stomp.pool.password2=marionette
plugin.stomp.pool.host3=activemq3.example.com
plugin.stomp.pool.port3=61613
plugin.stomp.pool.user3=mcollective
plugin.stomp.pool.password3=marionette

but the connector = stomp was replaced by connector = activemq 

Please fix the docs accordingly. The following conversation is from IRC on #libra

bleanhar: juhoffma: the are both using the stomp protocol
bleanhar: however the stomp.rb connector was deprecated upstream in favor of the activemq connector if you diff stomp.rb and activemq.rb they are very similar 
juhoffma: bleanhar: thanks for the explanation
juhoffma: bleanhar: in the ose 1.2 deployment guide section 5.8.4.4.3 we reference it for HA setups
juhoffma: bleanhar: is that a bug in the guide? https://access.redhat.com/site/documentation/en-US/OpenShift_Enterprise/1/html-single/Deployment_Guide/index.html#sect-Configuring_Redundancy
bleanhar: juhoffma: what specifically?
juhoffma: bleanhar: the docs say to configure connector=stomp
bleanhar: '5.8.4.4.3. Configuring MCollective for Redundant ActiveMQ Services' looks like it's wrong
juhoffma: for redundancy
bleanhar: the connector should be activemq everywhere the protocol is still stomp

Buddy

Note You need to log in before you can comment on or make changes to this bug.