Bug 1009172 - dracut-modules-growroot does not enlarge /dev/mmcblk0
dracut-modules-growroot does not enlarge /dev/mmcblk0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cloud-initramfs-tools (Show other bugs)
20
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juerg Haefliger
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker F20FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-09-17 17:42 EDT by Paul Whalen
Modified: 2013-12-20 21:09 EST (History)
4 users (show)

See Also:
Fixed In Version: cloud-initramfs-tools-0.20-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 23:51:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
growroot script (2.06 KB, text/plain)
2013-10-22 13:03 EDT, Juerg Haefliger
no flags Details

  None (edit)
Description Paul Whalen 2013-09-17 17:42:55 EDT
Description of problem:
Arm images use dracut-modules-growroot to enlarge the root partition on first boot. This is working well for '/dev/sda', however '/dev/mmcblk0' fails to be resized. 

Version-Release number of selected component (if applicable):
dracut-modules-growroot-0.20-0.4.bzr85.fc19.noarch

How reproducible:
everytime

Steps to Reproduce:
1. Boot F20 Alpha RC3 on SD card on any arm device

Actual results:
Root partition remains the original size. 

Expected results:
Root partition extended to fill media. 


Additional info:
Confirmed working on sda.
Comment 1 Juerg Haefliger 2013-09-19 01:54:34 EDT
Do you happen to have a pointer to an ARM image that I could use for investigating the problem?
Comment 2 Paul Whalen 2013-09-19 09:51:35 EDT
Juerg, The latest and greatest is here - https://dl.fedoraproject.org/pub/alt/stage/20-Alpha-RC4/Images/armhfp/

Thanks for looking at this.
Comment 3 Juerg Haefliger 2013-09-25 05:45:38 EDT
Confirmed. Growroot does not properly identify the root disk:

messages:Sep 25 05:27:46 localhost dracut-pre-pivot: growroot: FAILED: /dev/mmcblk0p: does not exist
Comment 4 Juerg Haefliger 2013-10-22 06:30:39 EDT
Sorry this is taking so long. I've been distracted by other work and there is another problem lurking behind this bug (see https://bugzilla.redhat.com/show_bug.cgi?id=1016648). I believe I have a fix now but need to do some more testing.
Comment 5 Kyle McMartin 2013-10-22 11:58:06 EDT
Could you share your fix? I can test it... I've been working on this as well, using sysfs to properly go from partitions to devices, instead of relying on games with the disk names to figure things out.

regards, Kyle
Comment 6 Juerg Haefliger 2013-10-22 13:02:19 EDT
Agreed, the script mangling of the device name is ugly. Love to see your work!
Comment 7 Juerg Haefliger 2013-10-22 13:03:29 EDT
Created attachment 815101 [details]
growroot script

Running the attached in dracut's pre-mount stage works for me.
Comment 8 Fedora Update System 2013-11-22 08:10:19 EST
cloud-initramfs-tools-0.20-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cloud-initramfs-tools-0.20-2.fc20
Comment 9 Fedora Update System 2013-11-22 08:28:19 EST
cloud-initramfs-tools-0.20-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cloud-initramfs-tools-0.20-2.fc19
Comment 10 Fedora Update System 2013-11-22 08:40:08 EST
cloud-initramfs-tools-0.20-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/cloud-initramfs-tools-0.20-2.el6
Comment 11 Paul Whalen 2013-11-22 11:10:53 EST
Tested on BeagleBone Black with mmcblk0, confirmed root partition is resized. The root filesystem requires a manual resize, should this also be handled?
Comment 12 Juerg Haefliger 2013-11-23 06:33:59 EST
(In reply to Paul Whalen from comment #11)
> Tested on BeagleBone Black with mmcblk0, confirmed root partition is
> resized. The root filesystem requires a manual resize, should this also be
> handled?

No. This package only resizes the partition. Filesystem resizing is up to cloud-init. I understand that ARM (mis-)uses this package for the purpose of expanding the image to the max size. Maybe we should consider a separate package for this that runs completely in post-initrd since newer kernels support online partition resizing. And the cloud-initramfs-tools package is likely to go away in F21.
Comment 13 Peter Robinson 2013-11-24 18:33:00 EST
> No. This package only resizes the partition. Filesystem resizing is up to
> cloud-init. I understand that ARM (mis-)uses this package for the purpose of
> expanding the image to the max size. Maybe we should consider a separate
> package for this that runs completely in post-initrd since newer kernels
> support online partition resizing. And the cloud-initramfs-tools package is
> likely to go away in F21.

I think it's worth splitting it out, or moving it over as a subpackage of dracut
Comment 14 Paul Whalen 2013-11-25 13:55:18 EST
Proposing as a freeze exception: This fixes root partition resize on ARM - tested on vexpress using vda or mmcblk, BeagleBone Black.
Comment 15 Fedora Update System 2013-11-25 23:51:52 EST
cloud-initramfs-tools-0.20-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-12-20 11:52:48 EST
cloud-initramfs-tools-0.20-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-12-20 21:09:07 EST
cloud-initramfs-tools-0.20-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.