Bug 1009180 - Nova compute drivers should not change hostname while running
Nova compute drivers should not change hostname while running
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
All Linux
medium Severity medium
: rc
: 4.0
Assigned To: Nikola Dipanov
Ami Jeain
:
Depends On: 1009179
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 18:21 EDT by Dan Smith
Modified: 2016-04-26 14:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.23.rc1.el6
Doc Type: Bug Fix
Doc Text:
Previously, updating a node's hostname while openstack-nova-compute was running on it changed the hostname that nova-compute reported to the controller as well. Whenever this occurred, the controller created a new record for the host, leaving the old record to go stale. With this release, openstack-nova-compute will no longer report changes to the node's hostname during runtime. Rather, nova-compute will simply log the hostname change; the node will not use the new hostname until openstack-nova-compute is restarted.
Story Points: ---
Clone Of: 1009179
Environment:
Last Closed: 2013-12-19 19:24:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1224982 None None None Never
OpenStack gerrit 46738 None None None Never

  None (edit)
Description Dan Smith 2013-09-17 18:21:26 EDT
+++ This bug was initially created as a clone of Bug #1009179 +++

Description of problem:

If the system changes its hostname while nova-compute is running, the resource update function will delete the compute_node record for the old hostname, rendering the host unusable by the scheduler until restart.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Start nova-compute
2. Change hostname/DNS such that that "virsh hostname" returns a different value
3. Note the compute record is deleted in the database after the next periodic update cycle

Actual results:

The compute_node record is deleted in the database and the scheduler fails to schedule instances on the node until nova-compute is restarted.

Expected results:

The node does not accept the changed name while running, delete the record, but rather warns the administrator about the detected change.
Comment 4 Ami Jeain 2013-12-02 09:57:13 EST
VERIFICATION:

1. Change hostname of the system to e.g. test.lab
2. Check out the /var/log/nova/compute.log

2013-12-02 11:15:18.897 8752 ERROR nova.virt.libvirt.driver [-] Hostname has changed from cougar14.scl.lab.tlv.redhat.com to test.lab. A restart is required to take effect.

3. The node does not accept the changed name while running and errors the administrator about the detected change.
Comment 7 errata-xmlrpc 2013-12-19 19:24:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.