Bug 1009191 - Content spec warning validation messages is incorrect
Content spec warning validation messages is incorrect
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.2
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 19:59 EDT by Lee Newson
Modified: 2013-10-17 19:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1008797
Environment:
Last Closed: 2013-10-17 19:49:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-09-17 19:59:47 EDT
+++ This bug was initially created as a clone of Bug #1008797 +++

Splitting this since the original bug had three problems in one report.

Description of problem:

The warning message for topic titles that have been replaced due to mismatching titles isn't very helpful. It should be something like: "Possible Invalid Topic! The specified topic title didn't match and was replaced, please check that you used the right topic."
Comment 1 Lee Newson 2013-09-17 20:57:17 EDT
Fixed in 1.2-SNAPSHOT Build 201309181050

The text is now:

Possible Invalid Topic! The specified topic title doesn't match, so it was replaced. Please verify that the topic used was correct.

The text for invalid relationship titles is:

Possible Invalid Relationship! The topic/target relationship title specified doesn't match the actual topic/target title, so it was replaced. Please verify that the topic/target used was correct.
Comment 2 Lee Newson 2013-10-09 00:48:03 EDT
This version is currently live on the dev server.
Comment 3 Lee Newson 2013-10-09 00:50:44 EDT
Tested by changing setting this in a content spec:

About [254]

When saving this was the error message:

WARN:  Line 24: Possible Invalid Topic! The specified topic title doesn't match, so it was replaced. Please verify that the topic used was correct.
       -> Specified: About
       -> Topic 254: About the Red Hat Customer Portal

and the topic was adjusted in the content spec to:

About the Red Hat Customer Portal [254]

Note You need to log in before you can comment on or make changes to this bug.