Bug 1009238 - Dependencies far too broad (requires the whole of erlang)
Dependencies far too broad (requires the whole of erlang)
Status: CLOSED DUPLICATE of bug 784693
Product: Fedora
Classification: Fedora
Component: ejabberd (Show other bugs)
rawhide
All All
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 23:58 EDT by Adam Williamson
Modified: 2013-09-18 00:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 00:11:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-09-17 23:58:01 EDT
ejabberd.spec has:

Requires:       erlang

That's way too broad. erlang is a metapackage which pulls in the whole of erlang, including for e.g. erlang-wx . Here's what happens if you do 'yum install ejabberd' on a fairly minimal install:

Installing:
 ejabberd                x86_64  2.1.13-1.fc19                   updates  931 k
Installing for dependencies:
 erlang                  x86_64  R16B-01.1.fc19                  updates   28 k
 erlang-appmon           x86_64  R16B-01.1.fc19                  updates  136 k
 erlang-asn1             x86_64  R16B-01.1.fc19                  updates  766 k
 erlang-common_test      x86_64  R16B-01.1.fc19                  updates  708 k
 erlang-compiler         x86_64  R16B-01.1.fc19                  updates  1.0 M
 erlang-cosEvent         x86_64  R16B-01.1.fc19                  updates  152 k
 erlang-cosEventDomain   x86_64  R16B-01.1.fc19                  updates  117 k
 erlang-cosFileTransfer  x86_64  R16B-01.1.fc19                  updates  172 k
 erlang-cosNotification  x86_64  R16B-01.1.fc19                  updates  737 k
 erlang-cosProperty      x86_64  R16B-01.1.fc19                  updates  165 k
 erlang-cosTime          x86_64  R16B-01.1.fc19                  updates  110 k
 erlang-cosTransactions  x86_64  R16B-01.1.fc19                  updates  169 k
 erlang-crypto           x86_64  R16B-01.1.fc19                  updates   83 k
 erlang-debugger         x86_64  R16B-01.1.fc19                  updates  542 k
 erlang-dialyzer         x86_64  R16B-01.1.fc19                  updates  653 k
 erlang-diameter         x86_64  R16B-01.1.fc19                  updates  648 k
 erlang-edoc             x86_64  R16B-01.1.fc19                  updates  318 k
 erlang-eldap            x86_64  R16B-01.1.fc19                  updates   98 k
 erlang-erl_docgen       x86_64  R16B-01.1.fc19                  updates  151 k
 erlang-erl_interface    x86_64  R16B-01.1.fc19                  updates  181 k
 erlang-erts             x86_64  R16B-01.1.fc19                  updates  2.2 M
 erlang-esasl            x86_64  0.1-11.20120116git665cc80.fc19  fedora    37 k
 erlang-et               x86_64  R16B-01.1.fc19                  updates  222 k
 erlang-eunit            x86_64  R16B-01.1.fc19                  updates  148 k
 erlang-examples         x86_64  R16B-01.1.fc19                  updates  1.1 M
 erlang-gs               x86_64  R16B-01.1.fc19                  updates  625 k
 erlang-hipe             x86_64  R16B-01.1.fc19                  updates  991 k
 erlang-ic               x86_64  R16B-01.1.fc19                  updates  882 k
 erlang-inets            x86_64  R16B-01.1.fc19                  updates  804 k
 erlang-jinterface       x86_64  R16B-01.1.fc19                  updates   97 k
 erlang-kernel           x86_64  R16B-01.1.fc19                  updates  1.1 M
 erlang-megaco           x86_64  R16B-01.1.fc19                  updates  5.4 M
 erlang-mnesia           x86_64  R16B-01.1.fc19                  updates  698 k
 erlang-observer         x86_64  R16B-01.1.fc19                  updates  553 k
 erlang-odbc             x86_64  R16B-01.1.fc19                  updates   66 k
 erlang-orber            x86_64  R16B-01.1.fc19                  updates  943 k
 erlang-os_mon           x86_64  R16B-01.1.fc19                  updates  112 k
 erlang-otp_mibs         x86_64  R16B-01.1.fc19                  updates   29 k
 erlang-parsetools       x86_64  R16B-01.1.fc19                  updates  175 k
 erlang-percept          x86_64  R16B-01.1.fc19                  updates  147 k
 erlang-pman             x86_64  R16B-01.1.fc19                  updates  110 k
 erlang-public_key       x86_64  R16B-01.1.fc19                  updates  528 k
 erlang-reltool          x86_64  R16B-01.1.fc19                  updates  356 k
 erlang-runtime_tools    x86_64  R16B-01.1.fc19                  updates  162 k
 erlang-sasl             x86_64  R16B-01.1.fc19                  updates  289 k
 erlang-snmp             x86_64  R16B-01.1.fc19                  updates  1.5 M
 erlang-ssh              x86_64  R16B-01.1.fc19                  updates  389 k
 erlang-ssl              x86_64  R16B-01.1.fc19                  updates  461 k
 erlang-stdlib           x86_64  R16B-01.1.fc19                  updates  2.2 M
 erlang-syntax_tools     x86_64  R16B-01.1.fc19                  updates  333 k
 erlang-test_server      x86_64  R16B-01.1.fc19                  updates  275 k
 erlang-toolbar          x86_64  R16B-01.1.fc19                  updates   52 k
 erlang-tools            x86_64  R16B-01.1.fc19                  updates  561 k
 erlang-tv               x86_64  R16B-01.1.fc19                  updates  394 k
 erlang-typer            x86_64  R16B-01.1.fc19                  updates   63 k
 erlang-webtool          x86_64  R16B-01.1.fc19                  updates   48 k
 erlang-wx               x86_64  R16B-01.1.fc19                  updates  2.9 M
 erlang-xmerl            x86_64  R16B-01.1.fc19                  updates  998 k
 gd                      x86_64  2.0.35-24.fc19                  fedora   144 k
 ghostscript             x86_64  9.07-12.fc19                    updates  4.3 M
 ghostscript-fonts       noarch  5.50-30.fc19                    fedora   324 k
 graphviz                x86_64  2.30.1-10.fc19                  updates  1.3 M
 gtk2                    x86_64  2.24.19-3.fc19                  updates  3.4 M
 gts                     x86_64  0.7.6-22.20111025.fc19          fedora   217 k
 lasi                    x86_64  1.1.1-6.fc19                    fedora    48 k
 libICE                  x86_64  1.0.8-5.fc19                    fedora    62 k
 libSM                   x86_64  1.2.1-5.fc19                    fedora    37 k
 libXaw                  x86_64  1.0.11-5.fc19                   fedora   186 k
 libXfont                x86_64  1.4.5-4.fc19                    fedora   139 k
 libXmu                  x86_64  1.1.1-4.fc19                    fedora    68 k
 libXpm                  x86_64  3.5.10-4.fc19                   fedora    51 k
 libXt                   x86_64  1.1.4-5.fc19                    fedora   168 k
 libfontenc              x86_64  1.1.1-3.fc19                    fedora    28 k
 libgsasl                x86_64  1.8.0-2.fc19                    fedora   126 k
 libntlm                 x86_64  1.4-1.fc19                      updates   50 k
 librsvg2                x86_64  2.37.0-3.fc19                   fedora   121 k
 libtool-ltdl            x86_64  2.4.2-16.fc19                   fedora    48 k
 lksctp-tools            x86_64  1.0.13-1.fc19                   fedora    87 k
 mesa-libGLU             x86_64  9.0.0-2.fc19                    fedora   194 k
 netpbm                  x86_64  10.61.02-5.fc19                 updates  177 k
 poppler-data            noarch  0.4.6-2.fc19                    fedora   2.2 M
 tcl                     x86_64  1:8.5.14-1.fc19                 updates  1.9 M
 tk                      x86_64  1:8.5.14-1.fc19                 updates  1.4 M
 unixODBC                x86_64  2.3.1-6.fc19                    updates  405 k
 urw-fonts               noarch  2.4-15.fc19                     fedora   3.0 M
 usermode                x86_64  1.111-3.fc19                    fedora   193 k
 wxBase                  x86_64  2.8.12-8.fc19                   fedora   577 k
 wxGTK                   x86_64  2.8.12-8.fc19                   fedora   2.9 M
 wxGTK-gl                x86_64  2.8.12-8.fc19                   fedora    33 k
 xorg-x11-font-utils     x86_64  1:7.5-17.fc19                   updates   86 k

Transaction Summary
================================================================================
Install  1 Package (+90 Dependent packages)

Total download size: 59 M
Installed size: 144 M

that seems far too much, including two(!) graphical toolkits for a server with no UI.

Debian's package picks out its erlang deps:

http://packages.debian.org/sid/ejabberd

Fedora's should do the same. I'll look and see if I can come up with a patch, but I'm just starting out with ejabberd, so it might be better coming from an 'expert'.
Comment 1 Adam Williamson 2013-09-18 00:03:31 EDT
ah, debian's package depends on something called 'erlang-nox' - http://packages.debian.org/sid/erlang-nox - which is a metapackage for all non-graphical erlang stuff. that may still be too much, but it might be a nice improvement for fedora's erlang to have a similar metapackage. Doesn't look like it does yet.
Comment 2 Adam Williamson 2013-09-18 00:11:48 EDT

*** This bug has been marked as a duplicate of bug 784693 ***

Note You need to log in before you can comment on or make changes to this bug.