Bug 1009241 - [asus_laptop] rfkill not correctly handled on ASUS X550C
Summary: [asus_laptop] rfkill not correctly handled on ASUS X550C
Keywords:
Status: CLOSED DUPLICATE of bug 954070
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-18 04:10 UTC by Yi Li
Modified: 2014-02-26 02:16 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 02:16:02 UTC


Attachments (Terms of Use)

Description Yi Li 2013-09-18 04:10:58 UTC
Description of problem:
on my laptop, NM can not scan wireless ssid when click "enable wireless", but from command line, with wpa_supplicant can. 
Here is some command output:
[codedancer@localhost]~/tmp/new_test2% lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d4)
00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d4)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM86 Express LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 8 Series Chipset Family 4-port SATA Controller 1 [IDE mode] - Mobile (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 8 Series/C220 Series Chipset Family 2-port SATA Controller 2 [IDE mode] (rev 04)
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 745M] (rev a1)
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
04:00.0 Ethernet controller: Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)
[codedancer@localhost]~/tmp/new_test2% ethtool -i wlp3s0
driver: ath9k
version: 3.9.5-301.fc19.x86_64
firmware-version: N/A
bus-info: 0000:03:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no
[codedancer@localhost]~/tmp/new_test2%

Version-Release number of selected component (if applicable):
NetworkManager-0.9.9.0-11.git20130913.fc20.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Can not enable wireless.
When Clicked, it un-check the button automaticly.

Expected results:
NM can detect wireless access point and connect it.

Additional info:

Comment 1 Gergely Polonkai 2013-11-04 23:17:33 UTC
The same goes for me; same network adapter, NM is 0.9.8.8, the machine is an ASUS X550C. I'm running the latest available kernel as of date (3.11.6-200.fc19.x86_64). Fedora is freshly installed from networkless DVD, this is my first attempt to connect to a network. Secure boot is on, and I'm unwilling to disable it due to company policy. The only difference between original report and my problem, is that NM reports to me that WiFi hardware is disabled.

As I think NM doesn't have anything to do with this problem, I issued rfkill:

$ sudo rfkill list
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
17: asus-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
18: asus-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no

WiFi hardware switch key (Fn-F2) doesn't seem to do anything (no output in dmesg, nor in syslog), the WiFi status LED is constantly on (it is initially off, and gets turned on after the kernel is loaded). WiFi is working well in dual-booted Windows 8, and it is not turned off before reboot.

(Seemingly) relevant comment on an Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1172151/comments/28

The solution (reloading the wmi module with wapf=4) didn't help.

Comment 2 Jirka Klimes 2013-11-08 10:46:20 UTC
Does pressing (Fn-F2) influence rfkill list output?
Are you able to unblock the Wi-Fi with 'sudo rfkill unblock all'?
Does 'rmmod asus-wlan' influence the behaviour?

Comment 3 Gergely Polonkai 2013-11-08 10:56:17 UTC
As the card is hard blocked, rfkill unblock can do nothing. As I mentioned in my comment, pressing Fn-F2 does nothing, and I can't even see anything in the logs.

Since then, however, it turned out that if I blacklist the asus-nb-wmi kernel module, the problem disappears (simply doing rmmod doesn't help).

Comment 4 Peter H. Jones 2013-12-07 19:30:11 UTC
In Fedora-Live-Jam-KDE-x86_64-20-Beta-5.iso, when I go to the Network Manager toolbox and enable networking, I get a message saying something like "Network Manager 0.8.8 needed, found", and the end seems cut off. I don't see the wireless networks there, but I do with iwlist scan.

rpm -qa | grep Network gives:
NetworkManager-openswan-0.9.8.0-1.fc20.x86_64
NetworkManager-pptp-0.9.8.2-3.fc20.x86_64
NetworkManager-glib-0.9.9.0-14.git20131003.fc20.x86_64
NetworkManager-openvpn-0.9.8.2-3.fc20.x86_64
NetworkManager-l2tp-0.9.8-2.fc20.x86_64
NetworkManager-0.9.9.0-14.git20131003.fc20.x86_64
NetworkManager-openconnect-0.9.8.0-2.fc20.x86_64
KNetworkKManager-vpnc-0.9.8.2-2.fc20.x86_64

So, Network is 0.9.9, not 0.9.8

Comment 5 Dan Williams 2013-12-18 18:06:32 UTC
(In reply to Gergely Polonkai from comment #3)
> As the card is hard blocked, rfkill unblock can do nothing. As I mentioned
> in my comment, pressing Fn-F2 does nothing, and I can't even see anything in
> the logs.
> 
> Since then, however, it turned out that if I blacklist the asus-nb-wmi
> kernel module, the problem disappears (simply doing rmmod doesn't help).

If 'rfkill list' shows that the wifi is hardblocked and you cannot unblock it, that's a kernel problem that needs to be fixed in the drivers for your laptop, like you've found.  NetworkManager is simply reporting what the kernel says.

Sometimes the kernel is wrong, and the rfkill "switch" it shows has no relation to the wifi card you've installed, which is often true of you have changed the wifi card in your machine.  Unfortunately the kernel does not tell NetworkManager about this (and it cannot do so easily), so there's no way to override the kernel here.  Even if there was, we'd rather have the kernel fixed than hack around it in userspace.

So the core problem here is likely that the platform/laptop drivers for your machine are not working correctly, and that needs to be fixed in the kernel.

Comment 6 Jon Dufresne 2014-01-19 18:11:00 UTC
I am running into the same issue. I have discovered a workaround to get the wireless device into a working state.

0. Do a cold boot (wifi not working)
1. Close lid to put laptop to sleep
2. Open lid and restore session (wifi working)

After bringing the laptop back from sleep, the wifi begins to work. This is my rfkill after resume from sleep:

$ sudo rfkill list
0: asus-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

So it appears the driver can work with the wireless device, just not on initial boot.

Comment 7 Jon Dufresne 2014-01-19 18:15:54 UTC
This looks like it may be a duplicate of bug 954070

Comment 8 Justin M. Forbes 2014-02-24 13:54:12 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 9 Jon Dufresne 2014-02-26 02:16:02 UTC

*** This bug has been marked as a duplicate of bug 954070 ***


Note You need to log in before you can comment on or make changes to this bug.