Bug 1009401 - virt-who: rhevm mode not supported in rhel 5.10
virt-who: rhevm mode not supported in rhel 5.10
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Novacek
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 07:19 EDT by gaoshang
Modified: 2016-11-30 19:31 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-who-0.9-1.el5
Doc Type: Enhancement
Doc Text:
Feature: Support for RHEV-M virtualization backend in virt-who. Reason: This feature was missing in 0.7 version of virt-who. Result: Customer can use virt-who on RHEL-5.11 to gather host/guest associations from RHEV-M.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:29:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gaoshang 2013-09-18 07:19:14 EDT
Description of problem:
virt-who: rhevm mode not surpported in rhel 5.10, please see following command running result:

# virt-who --rhevm --rhevm-owner=ACME_Corporation --rhevm-env=Library --rhevm-server=https://10.66.78.67:443 --rhevm-username=admin@internal --rhevm-password=redhat -b -d
usage: Agent for reporting virtual guest IDs to subscription-manager

virt-who.py: error: no such option: --rhevm


Version-Release number of selected component (if applicable):


How reproducible:
alwasy

Steps to Reproduce:
1. Add rhel 5.10 host in rhevm 3.0
2. run virt-who in rhevm mode

Actual results:
rhevm mode is not supported

Expected results:
rhevm mode should be supported

Additional info:
Comment 1 Radek Novacek 2013-09-18 09:22:05 EDT
RHEV-M mode is not supported in virt-who 0.7, there is a rebase request, see bug 975340. The rebase will also fix this issue.
Comment 2 RHEL Product and Program Management 2014-01-29 05:34:00 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Radek Novacek 2014-03-24 09:18:33 EDT
Shi Hui Liu from QA team reports that this bug is no longer reproducible with virt-who-0.9-1.el5, so I suppose that the rebase fixes it.
Comment 5 Liushihui 2014-04-27 23:32:25 EDT
Verified on virt-who-0.9-2.el5
Comment 7 errata-xmlrpc 2014-09-15 20:29:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1206.html

Note You need to log in before you can comment on or make changes to this bug.