Bug 1009407 - When creating a new vm, nic is assigned an empty profile, resulting in vm without networking
When creating a new vm, nic is assigned an empty profile, resulting in vm wit...
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.4
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lior Vernia
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 07:30 EDT by Nir Soffer
Modified: 2015-05-04 21:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 12:46:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nir Soffer 2013-09-18 07:30:28 EDT
Description of problem:

When creating a new vm, nic is assigned an empty profile by default, instead of ovirtmgmt. Adding a vm without changing this setting results in a vm without networking.

Version-Release number of selected component (if applicable):

3.4.0-master (9a22dd025067c)

How reproducible:
Always

Steps to Reproduce:
1. Open new vm dialog

Actual results:
nic profile is empty

Expected results:
nic profile is set to ovirtmgmt

Additional info:

Given how critical is network accesss to a vm, the default value must be ovirtmgmt profile.

If a vm without networking is useful in some cases, a second option "no profile" or "disabled" should be provided in the profile menu.
Comment 1 Nir Soffer 2013-09-18 07:35:06 EDT
Fixing vm  after creation:

1. Open the vm > network intefaces tab, select the nic and click edit
2. Set the nic profile to ovirtmgmt
Comment 2 Lior Vernia 2013-09-18 11:42:08 EDT
That actually does not sound like a bug to me. If a VM is created from a template, then that VM should have a network configuration similar to that template. So when creating from Blank, which doesn't have any profiles attached to VNICs, I would expect the resulting VM to not have any profiles attached to VNICs unless the user explicitly attached one.

In fact, Bug 1003779 states that it's a bug that there was even a VNIC to begin with, since Blank doesn't have any VNICs.
Comment 3 lpeer 2013-09-22 12:46:23 EDT
closing this bug, the fixed behaviour is that the VM would keep the same network configuration as the template, for more information look in bug 1009298 and in bug 1003799.

Note:

From the user point of view he wants to create a new instance (an instance from scratch), the fact that the user needs to choose a blank template is an implementation detailed we exposed to the user.
Most likely a new instance would need a VNIC, a user friendly behaviour in this case would be to propose a VNIC with a network.
The challenge in this case is to choose which default network to propose. We need to allocate a network which is a VM network, with profile and with a user permissions on that profile.
Given this challenge and given that we don't have a good suggestion how to solve this we'll keep current behaviour until we get a good suggestion on which network should be chosen.

Note You need to log in before you can comment on or make changes to this bug.