Bug 1009443 - Quartz DDL for Oracle DB execution ends with error message: ORA-00942 table or view does not exist
Quartz DDL for Oracle DB execution ends with error message: ORA-00942 table o...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER6
: 6.0.0
Assigned To: Ryan Zhang
Radovan Synek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 09:06 EDT by Radovan Synek
Modified: 2014-08-06 16:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2013-09-18 09:06:41 EDT
Description of problem:
Quartz DDL for Oracle (Supplementary tools) starts with delete and drop statements without checking existence of tables being deleted/dropped => this results in error message stated in the summary.

Version-Release number of selected component (if applicable):
BRMS/BPMS 6.0.0.ER3
Comment 1 Radovan Synek 2013-09-23 04:54:09 EDT
PostgreSQL shows very similar error message, the reason is probably the same - DDL script starts with DROP table commands without any checking.

On the other hand, script for DB2 does not drop any table. Would it be possible to unite this behaviour of DDL scripts for all supported DBs ?
Comment 3 Maciej Swiderski 2013-10-15 04:34:45 EDT
removed all drop/delete statements from DDL scripts as they are intended to be used to create new schemas and drop/delete might impose a risk of accidentally removing valid data.

jbpm
master:
https://github.com/droolsjbpm/jbpm/commit/8d42d2872e9984ff5ad7c922bd501341d9f28105

6.0.x
https://github.com/droolsjbpm/jbpm/commit/8ec9469691980e4efc4e02e4505f17a44fbb54ad
Comment 4 Radovan Synek 2013-11-27 11:03:41 EST
I cannot see any change here: dev138.mw.lab.eng.bos.redhat.com/candidate/bpms-6.0.0-ER5/jboss-bpms-brms-6.0.0-redhat-5-supplementary-tools.zip

DDL scripts still contain delete/drop statements, I am afraid the commits Maciej stated in comment 3 didn't get into the supplementary tools.
Comment 5 Maciej Swiderski 2013-11-29 06:10:39 EST
reassigning to Ryan as it's available in the source so it's just matter of moving that into right location on product side.

please also include following bz that fixes invalid column names in some of the tables:
https://bugzilla.redhat.com/show_bug.cgi?id=1035901
Comment 6 Ryan Zhang 2013-11-29 07:00:13 EST
Yes, product doesn't use the installer in community. 

Ok,  I will fix this in ER6.
Comment 8 Radovan Synek 2014-01-07 11:26:28 EST
Verified on BPMS-6.0.0.ER7

Note You need to log in before you can comment on or make changes to this bug.