Bug 100946 - rpm funkyness
rpm funkyness
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-27 15:35 EDT by Christopher McCrory
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 12:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher McCrory 2003-07-27 15:35:57 EDT
Description of problem:

for the opteron platform there can be multiple rpms installed with the same
name but different architectures  $package-amd64.rpm and $package-i386.rpm 

It is difficult to remove one without the other

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install taroon opteron
2. rpm -e ncurses-devel
3.
    
Actual results:
[chrismcc@office180 chrismcc]$ rpm -qf /usr/lib/libncurses.so.5.3
ncurses-5.3-4
[chrismcc@office180 chrismcc]$ rpm -qf /usr/lib64/libncurses.so.5.3
ncurses-5.3-4

[chrismcc@office180 chrismcc]$ sudo rpm -e ncurses
error: "ncurses" specifies multiple packages
error: Failed dependencies:
        libncurses.so.5 is needed by (installed) crash-3.5-2



Expected results:

works

Additional info:

[chrismcc@office180 chrismcc]$ sudo rpm -e crash
[chrismcc@office180 chrismcc]$ sudo rpm -e ncurses
error: "ncurses" specifies multiple packages
[chrismcc@office180 chrismcc]$ sudo rpm -e ncurses.i386
[chrismcc@office180 chrismcc]$ rpm -qf /usr/lib64/libncurses.so.5.3
ncurses-5.3-4


adding '.i386' seems to solve this , but as far as I can tell, this is not
documented anywhere
Comment 1 Jeff Johnson 2003-08-01 12:16:01 EDT
Yes not documented, because it's unclear atm whethere the rather
feeble mechanism of adding .arch is supportable at the moment.
It's pure mechanism, better policies are needed imho.

WONTFIX becuase it's too early to document a rather flimsy mechanism,
the issue of elf32 vs elf64 is a far, far more complicated issue.

Note You need to log in before you can comment on or make changes to this bug.