Bug 1009478 - RHQ server 2nd installation does not work when first installation fails
RHQ server 2nd installation does not work when first installation fails
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
x86_64 Linux
urgent Severity high
: ER03
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: jon32-Beta-Blockers-1006862
  Show dependency treegraph
 
Reported: 2013-09-18 10:16 EDT by jvlasak
Modified: 2014-01-02 15:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhq-installer.log (27.53 KB, text/x-log)
2013-10-11 09:58 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description jvlasak 2013-09-18 10:16:34 EDT
Description of problem:
2nd RHQ server installation does not work when first installation fails because of typo in rhq-server.properties or missing property


Version-Release number of selected component (if applicable):
Version: 4.10.0-SNAPSHOT
Build Number: 1e23623

How reproducible:
always

Steps to Reproduce:
1. wget http://hudson.qa.jboss.com/hudson/view/RHQ/job/rhq-master-gwt-locales/838/artifact/modules/enterprise/server/appserver/target/rhq-server-4.10.0-SNAPSHOT.zip
2. unzip it
3. edit RHQ_HOME/bin/rhq-server.properties file this way:
  a) set property jboss.bind.address to value 0.0.0.0   
  b) rhq.server.database.db-name=rhq replace with e.g. rhq.server.database.db.nam=rhq (changed property name) or remove this line from the file
4. run RHQ_HOME/bin/rhqctl install
5. put the RHQ_HOME/bin/rhq-server.properties file to the initial state except for jboss.bind.address value which is necessary
6. run RHQ_HOME/bin/rhqctl install

Actual results:
4. 
exception referring to RHQ server installation not informing the user about the problem is thrown:

07:33:38,453 WARN  [org.rhq.enterprise.server.installer.InstallerServiceImpl] reloadConfiguration failed - restart the server to complete the installation: java.io.IOException: java.util.concurrent.ExecutionException: Operation failed

RHQ server process is running

6.
RHQ server is not correctly installed

Expected results:
4.
exception referring to RHQ server installation informing the user about the certain problem is thrown

6.
RHQ server is correctly installed

Additional info:
Comment 1 John Mazzitelli 2013-09-26 08:18:49 EDT
this is being worked on. main master commit is b130f6a4194d944fae8fc582fca8f561c37922f9 but there are others that occurred after it.
Comment 2 John Mazzitelli 2013-10-01 08:54:03 EDT
The work I did on this has been completed with the git commit mentioned earlier.    What this does is - when the installer aborts half way through, it will attempt to rollback what it had done already, allowing the user to attempt to re-install a second time. Cleaning up remnants of the first attempt is necessary to allow for another attempt.
Comment 3 John Mazzitelli 2013-10-04 17:05:00 EDT
in addition to git commit b130f6a4194d944fae8fc582fca8f561c37922f9 these are also part of the fix:

d2410ab75b1274867bb9b7f378219974519e6426
52bd8ca8f3b5e16e4f79e011a906406410579844
d7d3a9af3e1099fe590d0213859ffcfa501de294
2361b825acc4f1da3a7ff5617638c8b2b98e42df
f36fa3e0f783f179cb1409c22ab67c1c961578e1
d1dc34f4c2fd223735ae2e1b2e242732611d03fc
87740ae36b3d268b125f390ae7072e924051b601
093b388081bafff554293bd24ed52d1157aed376
Comment 4 Simeon Pinder 2013-10-08 03:41:43 EDT
Moving to ON_QA for testing.
Comment 5 Armine Hovsepyan 2013-10-11 09:57:17 EDT
vreified
after an unsuccessful install re-install installs server.

full rhq-installer.log attached
Comment 6 Armine Hovsepyan 2013-10-11 09:58:43 EDT
Created attachment 811135 [details]
rhq-installer.log

Note You need to log in before you can comment on or make changes to this bug.