Bug 1009499 - yum complicates config URIs needlessly, leading to strange error messages
yum complicates config URIs needlessly, leading to strange error messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: packaging-team-maint
Karel Srot
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 10:38 EDT by Jan Pokorný
Modified: 2014-10-14 00:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: yum-3.2.29-51.el6
Doc Type: Bug Fix
Doc Text:
NO DOCS NEEDED
Story Points: ---
Clone Of:
: 1095146 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:36:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-09-18 10:38:05 EDT
# echo "exclude=" > /etc/yum.repos.d/test.repo
# yum search foo
> Error: File contains no section headers.
> file: file://///etc/yum.repos.d/test.repo, line: 1
> 'exclude=\n

IOW, the path of repository config is tracked as
///etc/yum.repos.d/test.repo (also confirmed by looking with debugger
around getReposFromConfigFile method: repofn was OK for /etc/yum.conf
but needlessly extended for files under /etc/yum.repos.d/.

yum-3.2.29-40.el6.noarch (confirmed also with yum-3.4.3-54.fc18.noarch)
Comment 2 Valentina Mukhamedzhanova 2014-03-27 11:58:32 EDT
Fixed in upstream - http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=bec81af1bffdd3c3511ad8861fb66b376bee89e9
Comment 8 errata-xmlrpc 2014-10-14 00:36:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1410.html

Note You need to log in before you can comment on or make changes to this bug.