Bug 1009524 - bug pirut
bug pirut
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: tar (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 11:09 EDT by Michele
Modified: 2013-09-18 11:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 11:14:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pirut (3.20 KB, text/plain)
2013-09-18 11:09 EDT, Michele
no flags Details

  None (edit)
Description Michele 2013-09-18 11:09:13 EDT
Created attachment 799437 [details]
pirut

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michele 2013-09-18 11:10:13 EDT
Component: pirut
Summary: TB3e4030d0 rhnserver.py:64:__call__:SSLCertificateVerifyFailedError: The SSL certificate failed verification.

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 361, in ?
    main()
  File "/usr/sbin/system-install-packages", line 354, in main
    pkginst = SinglePackageInstaller()
  File "/usr/sbin/system-install-packages", line 66, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 118, in doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 183, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 110, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 211, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 178, in login
    li = server.up2date.login(systemId)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 64, in __call__
    raise up2dateErrors.SSLCertificateVerifyFailedError()
SSLCertificateVerifyFailedError: The SSL certificate failed verification.

Local variables in innermost frame:
args: ('<?xml version="1.0"?>\n<params>\n<param>\n<value><struct>\n<member>\n<name>username</name>\n<value><string>it@ellemmeimpianti.it</string></value>\n</member>\n<member>\n<name>operating_system</name>\n<value><string>redhat-release</string></value>\n</member>\n<member>\n<name>description</name>\n<value><string>Initial Registration Parameters:\nOS: redhat-release\nRelease: 5Server\nCPU Arch: i686-redhat-linux</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>50fa171887bc9e0b7dd51235941da37c</string></value>\n</member>\n<member>\n<name>profile_name</name>\n<value><string>mailsrv1.ellemmeimpianti.it</string></value>\n</member>\n<member>\n<name>system_id</name>\n<value><string>ID-1011697165</string></value>\n</member>\n<member>\n<name>architecture</name>\n<value><string>i686-redhat-linux</string></value>\n</member>\n<member>\n<name>os_release</name>\n<value><string>5Server</string></value>\n</member>\n<member>\n<name>fields</name>\n<value><array><data>\n<value><string>system_id</string></value>\n<value><string>os_release</string></value>\n<value><string>operating_system</string></value>\n<value><string>architecture</string></value>\n<value><string>username</string></value>\n<value><string>type</string></value>\n</data></array></value>\n</member>\n<member>\n<name>type</name>\n<value><string>REAL</string></value>\n</member>\n</struct></value>\n</param>\n</params>\n',)
e: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]
self: <up2date_client.rhnserver._DoCallWrapper object at 0x8fdc9ac>
error: 'SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed'
pieces: ["'SSL routines'", " 'SSL3_GET_SERVER_CERTIFICATE'", " 'certificate verify failed'"]
kwargs: {}
message: certificate verify failed
Comment 2 Ondrej Vasik 2013-09-18 11:14:51 EDT
Thanks for report. RHEL-2.1 is already eoled and the component you filed is wrong (pirut is not related to tar). It actually seems you have wrong SSL certificate (maybe expired) and this is even not a bug. Closing WONTFIX, as in RHEL-2.1 this will not be fixed anyway.

Note You need to log in before you can comment on or make changes to this bug.