Bug 1009530 - IllegalArgumentException by HornetQ on server shutdown
IllegalArgumentException by HornetQ on server shutdown
Status: CLOSED DUPLICATE of bug 1003913
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JMS (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Mesnil
Miroslav Novak
Russell Dickenson
:
Depends On: 1016141
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 11:12 EDT by Petr Kremensky
Modified: 2013-10-07 11:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 11:37:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server logs (6.22 KB, application/x-zip-compressed)
2013-09-18 11:12 EDT, Petr Kremensky
no flags Details

  None (edit)
Description Petr Kremensky 2013-09-18 11:12:34 EDT
Created attachment 799439 [details]
Server logs

I've run into this exception in EAP clean startup smoke tests (solaris11-x86 - Oracle jdk 1.6.0_45 ). It is thrown while server is shutting down (job is using standard shutdown method: ./jboss-cli.sh -c command=/host=master:shutdown).

01:56:07,262 ERROR [org.jboss.messaging] (MSC service thread 1-11) JBAS011602: Exception while stopping JMS server: java.lang.IllegalArgumentException: Container is shutting down
	at org.jboss.msc.service.ServiceControllerImpl.internalSetMode(ServiceControllerImpl.java:684) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl.compareAndSetMode(ServiceControllerImpl.java:1320) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.as.messaging.jms.JMSService$1.deActivate(JMSService.java:107) [jboss-as-messaging-7.3.0.Final-redhat-4.jar:7.3.0.Final-redhat-4]
	at org.hornetq.core.server.impl.HornetQServerImpl.callDeActiveCallbacks(HornetQServerImpl.java:1382) [hornetq-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.server.impl.HornetQServerImpl.stop(HornetQServerImpl.java:607) [hornetq-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.server.impl.HornetQServerImpl.stop(HornetQServerImpl.java:538) [hornetq-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.server.impl.HornetQServerImpl.stop(HornetQServerImpl.java:505) [hornetq-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.jms.server.impl.JMSServerManagerImpl.stop(JMSServerManagerImpl.java:507) [hornetq-jms-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.jboss.as.messaging.jms.JMSService.stop(JMSService.java:124) [jboss-as-messaging-7.3.0.Final-redhat-4.jar:7.3.0.Final-redhat-4]
	at org.jboss.msc.service.ServiceControllerImpl$StopTask.stopService(ServiceControllerImpl.java:1911) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StopTask.run(ServiceControllerImpl.java:1874) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
	at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]

Affected version:
EAP 6.2.0.ER2

Additional info:
Exception is thrown by server-two (see attached server logs)
Comment 1 Clebert Suconic 2013-09-18 11:23:41 EDT
This is something on the integration. The JMS Server has to be stopped before the container.


It's nothing new here and introduced on this released.
Comment 2 Jeff Mesnil 2013-09-18 11:37:31 EDT
#1003913 backport will fix this problem.

*** This bug has been marked as a duplicate of bug 1003913 ***
Comment 3 Clebert Suconic 2013-09-18 11:38:10 EDT
I've sent a PR to avoid interrupting shutdown sequence:

https://github.com/hornetq/hornetq/pull/1291



The real fix here will be to change org.jboss.as.messaging.jms.JMSService$1.deActivate to ignore the exception! Simple change

Note You need to log in before you can comment on or make changes to this bug.