Bug 1009533 - Synchronization fails with a python stacktrace
Synchronization fails with a python stacktrace
Status: CLOSED DUPLICATE of bug 1017420
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 11:15 EDT by Og Maciel
Modified: 2014-01-27 09:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 11:55:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-09-18 11:15:43 EDT
Description of problem:

After importing a manifest I enabled the following products:

1.  Red Hat Enterprise Linux 5 Server RPMs i386 5Server
2.  Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server
3.  Red Hat Enterprise Linux 6 Server RPMs i386 5Server
4.  Red Hat Enterprise Linux 6 Server RPMs x86_64 5Server

I manually synchronized (3) and waited for its completion. I then manually synchronized the remaining (1), (2) and (4). After several minutes (1) and (2) failed to sync. I waited until (4) was completed and manually synchronized (1) and (2)... after several minutes (2) also failed.

The web ui only tells me that the synchronization failed but there's no indication as to the why. pulp.log shows:

2013-09-18 10:04:09,399 pulp_rpm.plugins.importers.yum.sync:ERROR: sync failed
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 116, in run
    self.update_content(metadata_files)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 239, in update_content
    rpms_to_download, drpms_to_download = self._decide_what_to_download(metadata_files)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 256, in _decide_what_to_download
    rpms_to_download, rpms_count, rpms_total_size = self._decide_rpms_to_download(metadata_files)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 288, in _decide_rpms_to_download
    wanted = self._identify_wanted_versions(package_info_generator)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 525, in _identify_wanted_versions
    for model in package_info_generator:
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/packages.py", line 74, in package_list_generator
    package_info = process_func(element)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/primary.py", line 183, in process_package_element
    model.raw_xml = utils.element_to_raw_xml(package_element, [rpm_namespace], COMMON_SPEC_URL)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/utils.py", line 88, in element_to_raw_xml
    register_namespace(namespace.name, namespace.uri)
  File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/utils.py", line 119, in register_namespace
    del ET._namespace_map[k]
KeyError: ''
2013-09-18 10:04:09,740 pulp.server.event.http:INFO: {'call_report': {'task_group_id': 'de22d996-5214-4dc8-b1c7-0463fa4beb39', 'exception': None, 'traceback': None, 'task_id': '7350ac28-bf3f-4330-9938-93c70163ba64', 'call_request_tags': [u'pulp:repository:Dungeon-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_RPMs_x86_64_5Server', 'pulp:action:sync'], 'reasons': [], 'start_time': '2013-09-18T13:43:05Z', 'tags': [u'pulp:repository:Dungeon-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_RPMs_x86_64_5Server', 'pulp:action:sync'], 'state': 'running', 'finish_time': None, 'dependency_failures': {}, 'schedule_id': None, 'progress': {u'yum_importer': {'content': {'size_total': 0, 'items_left': 0, 'items_total': 0, 'state': 'FAILED', 'size_left': 0, 'details': {'rpm_total': 0, 'rpm_done': 0, 'drpm_total': 0, 'drpm_done': 0}, 'error': "''", 'error_details': []}, 'comps': {'state': 'NOT_STARTED'}, 'distribution': {'items_total': 0, 'state': 'NOT_STARTED', 'error_details': [], 'items_left': 0}, 'errata': {'state': 'NOT_STARTED'}, 'metadata': {'state': 'FINISHED'}}}, 'call_request_group_id': 'de22d996-5214-4dc8-b1c7-0463fa4beb39', 'call_request_id': '7350ac28-bf3f-4330-9938-93c70163ba64', 'principal_login': u'admin', 'response': 'accepted', 'result': None}, 'event_type': 'repo.sync.finish', 'payload': {'importer_id': u'yum_importer', 'exception': None, 'repo_id': u'Dungeon-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_RPMs_x86_64_5Server', 'traceback': None, 'started': '2013-09-18T09:43:05-04:00', '_ns': u'repo_sync_results', 'completed': '2013-09-18T10:04:09-04:00', 'importer_type_id': u'yum_importer', 'error_message': None, 'summary': {'content': {'state': 'FAILED'}, 'comps': {'state': 'NOT_STARTED'}, 'distribution': {'state': 'NOT_STARTED'}, 'errata': {'state': 'NOT_STARTED'}, 'metadata': {'state': 'FINISHED'}}, 'added_count': 0, 'result': 'failed', 'updated_count': 1, 'details': {'content': {'size_total': 0, 'items_left': 0, 'items_total': 0, 'state': 'FAILED', 'size_left': 0, 'details': {'rpm_total': 0, 'rpm_done': 0, 'drpm_total': 0, 'drpm_done': 0}, 'error': "''", 'error_details': []}, 'comps': {'state': 'NOT_STARTED'}, 'distribution': {'items_total': 0, 'state': 'NOT_STARTED', 'error_details': [], 'items_left': 0}, 'errata': {'state': 'NOT_STARTED'}, 'metadata': {'state': 'FINISHED'}}, 'id': '5239b2d9b61d6f4a500075a2', 'removed_count': 0}}
2013-09-18 10:04:09,758 pulp.server.dispatch.task:ERROR: Importer indicated a failed response
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/dispatch/task.py", line 138, in _run
    result = call(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 116, in sync
    raise PulpExecutionException(_('Importer indicated a failed response'))
PulpExecutionException: Importer indicated a failed response
2013-09-18 10:04:09,783 pulp.server.dispatch.task:INFO: FAILURE: Task 7350ac28-bf3f-4330-9938-93c70163ba64: CallRequest: RepoSyncManager.sync(u'Dungeon-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_RPMs_x86_64_5Server', sync_config_override={'num_threads': 4})

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.2.1003-1.noarch
* foreman-compute-1.2.1003-1.noarch
* foreman-libvirt-1.2.1003-1.noarch
* foreman-postgresql-1.2.1003-1.noarch
* foreman-proxy-1.2.10003-1.el6sat.noarch
* katello-1.4.6-2.el6sat.noarch
* katello-all-1.4.6-2.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.3-2.el6sat.noarch
* katello-cli-1.4.3-12.el6sat.noarch
* katello-cli-common-1.4.3-12.el6sat.noarch
* katello-common-1.4.6-2.el6sat.noarch
* katello-configure-1.4.5-7.el6sat.noarch
* katello-configure-foreman-1.4.5-7.el6sat.noarch
* katello-configure-foreman-proxy-1.4.5-7.el6sat.noarch
* katello-foreman-all-1.4.6-2.el6sat.noarch
* katello-glue-candlepin-1.4.6-2.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-2.el6sat.noarch
* katello-glue-pulp-1.4.6-2.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.11.alpha.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.11.alpha.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.11.alpha.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.11.alpha.el6sat.noarch
* pulp-selinux-2.3.0-0.11.alpha.el6sat.noarch
* pulp-server-2.3.0-0.11.alpha.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.5-2.el6sat.noarch
* signo-0.0.20-2.el6sat.noarch
* signo-katello-0.0.20-2.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. Follow the steps indicated in the description
2.
3.

Actual results:


Expected results:


Additional info:

pulp.log attached
Comment 2 RHEL Product and Program Management 2013-09-18 11:16:59 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Mike McCune 2013-10-10 11:55:35 EDT

*** This bug has been marked as a duplicate of bug 1017420 ***

Note You need to log in before you can comment on or make changes to this bug.