Bug 1009537 - SAM 1.2.1 > 1.3 Upgrade Fails with large data.
SAM 1.2.1 > 1.3 Upgrade Fails with large data.
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
Hayk Hovsepyan
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-09-18 11:23 EDT by Hayk Hovsepyan
Modified: 2013-10-01 07:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:26:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
hhovsepy: automate_bug+


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-09-18 11:23:24 EDT
Description of problem:
Upgrading SAM 1.2.1 > 1.3 fails with large data set.
Katello-debug full log is attached.

Version-Release number of selected component (if applicable):
Upgrade to: http://download.devel.redhat.com/composes/candidates/SAM/SAM-1.3.0-RHEL-6-snapshot-6/compose/SAM/x86_64/os/

How reproducible:
always

Steps to Reproduce:
1. Install SAM 1.2.1
2. Create several orgs, environments, users, roles, permissions, upload manifest, activation keys, register several systems.
3. Delete some of above created objects.
4. Try to upgrade to SAM 1.3 Snap6.

Actual results:
Upgrade fails with several DB constraint issues and other issues. But SAM server is still running.  No any org can be deleted. Environments and all SAM 1.2.1 objects still exists which should be removed during upgrade.

Expected results:
Successful Upgrade.

Additional info:
Upgrade jenkins job console out is:
http://smqa-r210-01.lab.eng.brq.redhat.com:8080/view/SAM/job/dcloud_sam_upgrade/41/consoleFull
Comment 3 Bryan Kearney 2013-09-18 12:50:42 EDT
Snap 7 has changes which should address this. Please verify.
Comment 5 Hayk Hovsepyan 2013-09-23 03:52:33 EDT
Verified on latest Snap 7.1
Comment 7 errata-xmlrpc 2013-10-01 07:26:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.