Bug 1009573 - MongoDb backends are needed in collections languages [ruby193]
MongoDb backends are needed in collections languages [ruby193]
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: ruby (Show other bugs)
ruby193
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Vít Ondruch
Iveta Wiedermann
:
Depends On:
Blocks: 1009548
  Show dependency treegraph
 
Reported: 2013-09-18 12:00 EDT by Marcela Mašláňová
Modified: 2014-06-04 03:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: ruby193-rubygem-bson-1.9.2-1.el7, ruby193-rubygem-bson-1.9.2-1.el6, ruby193-rubygem-bson_ext-1.9.2-2.el7, ruby193-rubygem-bson_ext-1.9.2-2.el6, ruby193-rubygem-mongo-1.9.2-1.el7, ruby193-rubygem-mongo-1.9.2-1.el6
Doc Type: Enhancement
Doc Text:
Cause: By popular demand, MongoDB client library for ruby193 SCL was added. Consequence: Previously, it was not possible to acces MongoDB from Ruby without external libraries. Fix: MongoDB adapter was added to ruby193 SCL. Result: It is possible to access MongoDB databases from Ruby without installation of external libraries.
Story Points: ---
Clone Of:
: 1032922 (view as bug list)
Environment:
Last Closed: 2014-06-04 03:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2013-09-18 12:00:06 EDT
All languages must add MongoDb backend in their collection. For example perl-MongoDb. Please, look at possible backends and pick the most maintained one for RHSCL-1.1. The name of backend must be added into bugzilla for future work.
Comment 2 Troy Dawson 2013-10-15 09:42:32 EDT
Python: pymongo
Perl: perl-MongoDB
Php: php-pecl-mongo
Node.Js: nodejs-mongodb
Ruby: rubygem-mongo / rubygem-bson  (can't have mongo without bson)
Comment 5 errata-xmlrpc 2014-06-04 03:16:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0619.html

Note You need to log in before you can comment on or make changes to this bug.