Bug 1009583 - reserve workflow should not default to filtering by STABLE tag
reserve workflow should not default to filtering by STABLE tag
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15.1
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 12:16 EDT by mreynolds
Modified: 2018-02-05 19:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 02:59:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mreynolds 2013-09-18 12:16:50 EDT
Description of problem:

Select RedHatEnterpriseLinux7, but the "distro" and "tag" fields are not set, and no systems are listed in the lab field.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime

Steps to Reproduce:
 See above.

Actual results:

Rhel7 builds are listed, and system architectures are listed.


Expected results:

To be able to reserve a rhel7 machine

Additional info:
Comment 2 Bill Peck 2013-09-18 12:43:25 EDT
This is because the reserve workflow defaults to tag STABLE and no RHEL7 distros have been tagged stable.

You can change the tag to "None Selected" and you will then get a list.
Comment 3 mreynolds 2013-09-18 13:05:19 EDT
(In reply to Bill Peck from comment #2)
> This is because the reserve workflow defaults to tag STABLE and no RHEL7
> distros have been tagged stable.
> 
> You can change the tag to "None Selected" and you will then get a list.

Yup, you're correct.  I don't recall having to do that the last time I reserved a rhel7 machine, so that's what threw me off.

Thanks,
Mark
Comment 4 Bill Peck 2013-09-18 15:45:03 EDT
I'm guessing we don't have any distros that RTT considers STABLE.
Comment 5 Dan Callaghan 2013-09-18 19:11:49 EDT
Bill, you might be thinking of RTT_ACCEPTED which is the tag added by RTT.

STABLE is supposed to be set by addDistro.d/updateDistro when the distro has been installed successfully. But that only happens if add_distro=1 is set in /etc/sysconfig/beaker_lab_import and if --run-jobs is passed to beaker-import. It looks like our crusty old Perl script to invoke beaker-import does not pass --run-jobs. I'm not sure if/when that regressed, but it must have been a long time ago, judging by the fact that no distros have been tagged STABLE since we added tag auditing.

Defaulting to STABLE tag in the reserve workflow is probably not wise since it assumes the Beaker administrator has got that working properly (and that they actually want to run those jobs). We might be better off defaulting to no tag filtering in reserve workflow.
Comment 6 Nick Coghlan 2013-09-29 22:40:41 EDT
For 0.15.1, we'll switch the reserve workflow to not care about the distro tags by default.

For 0.16 and later, bug 958590 should mean distros start getting tagged more reliably, but that won't directly impact the resolution of this issue.
Comment 7 Raymond Mancy 2013-10-14 06:42:35 EDT
http://gerrit.beaker-project.org/#/c/2358/
Comment 10 Raymond Mancy 2013-10-23 02:59:43 EDT
beaker 0.15.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.