Bug 1009596 - [kickstart] Cannot use process substitution even if interpreter set to bash
[kickstart] Cannot use process substitution even if interpreter set to bash
Status: CLOSED DUPLICATE of bug 814850
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 12:40 EDT by Jan Pokorný
Modified: 2013-09-18 14:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 14:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-09-18 12:40:20 EDT
Cannot get kickstart file containing process substitution in %post
to work correctly.  Explicitly setting interpreter (--interpreter)
to /bin/bash won't help.

Either I am missing something or this is a bug.
Comment 3 Jan Pokorný 2013-09-18 14:11:02 EDT
Found /tmp/ks-script-wauWIy (standalone %post section) and the respective
/tmp/ks-script-wauWIy.log states:

> cat: /dev/fd/63: No such file or directory
> cat: /dev/fd/62: No such file or directory
> tail: write error: Broken pipe

(where tail is one of the two commands used for process substitutions)

Looks like the chroot environment is not built properly incl. /dev
hierarchy (if possible, indeed, not a chroot expert), effectively
preventing process substitution?  If it's a known limitation, it doesn't
seem to be properly documented.  Definitely more desired would be to
prevent any such artificial and unobvious limitations
(process substitution is a standard feature of bash).
Comment 4 Jan Pokorný 2013-09-18 14:38:49 EDT
Oh, [bug 814850].

*** This bug has been marked as a duplicate of bug 814850 ***

Note You need to log in before you can comment on or make changes to this bug.