Bug 1009600 - Show System Type in list --consumed; Show System Type in attach confirmation gui dialog.
Show System Type in list --consumed; Show System Type in attach confirmatio...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-18 12:51 EDT by Michael Stead
Modified: 2013-11-21 16:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Add System Type: Virtual/Physical to the output. Reason: Allows the user to determine if the entitlement granted was virtual. Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:29:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Type of subscription being attached (404.79 KB, image/png)
2013-09-24 17:14 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Michael Stead 2013-09-18 12:51:03 EDT
Description of problem:
After a subscription is attached, there is no way via 'list --consumed' to determine if the entitlement granted was virtual.

Add System Type: Virtual/Physical  to the output.


Durning an autobind in the GUI, once the best pools for an SLA are selected, there is no way to determine in the confirmation dialog if the subscription is for a Virtual or Physical machine.

Add a Type: Virtual/Physical column to the confirm subscription list.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

CLI
1. Attach a virtual and physical subscription.
2. Run: subscription-manager list --consumed
3. System Type: [Physical|Virtual] should be displayed

GUI
1. Start autobind in the GUI during registration (or by clicking the Auto-Attach button.
2. After SLA selection (if more than one match) the confirmation dialog will show the selected subscriptions.
3. There should be a Type column showing Virtual or Physical for each selected subscription.
Comment 1 Michael Stead 2013-09-18 12:53:25 EDT
Fixed by: https://github.com/candlepin/subscription-manager/pull/770
Comment 3 John Sefler 2013-09-24 12:26:42 EDT
CLI Verification...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.9.7-1.el6.x86_64


[root@jsefler-6 ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: RAM Limiting Package (8GB)
SKU:               ram-8gb
Pool ID:           8a9086d3414bd57701414bd72a4707ef
Available:         10
Suggested:         1
Service Level:     None
Service Type:      
Multi-Entitlement: No
Ends:              09/22/2014
System Type:       Physical

Subscription Name: Awesome OS with unlimited virtual guests
SKU:               awesomeos-virt-unlimited
Pool ID:           8a9086d3414bd57701414bd7295007a6
Available:         Unlimited
Suggested:         1
Service Level:     None
Service Type:      
Multi-Entitlement: No
Ends:              09/22/2014
System Type:       Virtual

[root@jsefler-6 ~]# subscription-manager attach --pool 8a9086d3414bd57701414bd72a4707ef --pool 8a9086d3414bd57701414bd7295007a6
Successfully attached a subscription for: RAM Limiting Package (8GB)
Successfully attached a subscription for: Awesome OS with unlimited virtual guests

[root@jsefler-6 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS with unlimited virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-unlimited
Contract:          145
Account:           12331131231
Serial:            7742634658980306046
Pool ID:           8a9086d3414bd57701414bd7295007a6
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    
Starts:            09/22/2013
Ends:              09/22/2014
System Type:       Virtual              <========= VERIFIED

Subscription Name: RAM Limiting Package (8GB)
Provides:          RAM Limiting Product
SKU:               ram-8gb
Contract:          169
Account:           12331131231
Serial:            7381188811441014251
Pool ID:           8a9086d3414bd57701414bd72a4707ef
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    
Starts:            09/22/2013
Ends:              09/22/2014
System Type:       Physical             <========= VERIFIED

[root@jsefler-6 ~]# 


VERIFIED: The CLI list --consumed now displays the System Type corresponding to the pool that the entitlement came from.
Comment 4 Sharath Dwaral 2013-09-24 17:14:08 EDT
Created attachment 802475 [details]
Type of subscription being attached

Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.9.7-1.el6.x86_64
subscription-manager-migration-1.9.7-1.el6.x86_64
subscription-manager-firstboot-1.9.7-1.el6.x86_64
python-rhsm-debuginfo-1.9.6-1.el6.x86_64
subscription-manager-debuginfo-1.9.7-1.el6.x86_64
python-rhsm-1.9.6-1.el6.x86_64
subscription-manager-gui-1.9.7-1.el6.x86_64

Verification:

See Attachment

VERIFIED
Comment 5 errata-xmlrpc 2013-11-21 16:29:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.