Bug 1009670 - cannot create IDN entry in DNS
cannot create IDN entry in DNS
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bašti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 16:22 EDT by Tomasz Torcz
Modified: 2014-07-09 04:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-09 04:05:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2013-09-18 16:22:39 EDT
Description of problem:
When I try to add punycode-encoded IDN name into FreeIPA managed DNS, I get following error:

#v+
Record name: xn--dogstaff-33b
>>> Record name: only letters, numbers, _, and - are allowed. DNS label may not start or end with -
#v-

looks like regex in util.py:validate_dns_label() is too restrictive.

Version-Release number of selected component (if applicable):
freeipa-python-3.3.0-2.fc19.x86_64

How reproducible:
Always.
Comment 1 Rob Crittenden 2013-09-18 16:26:19 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3169
Comment 2 Rob Crittenden 2013-09-18 16:27:15 EDT
punycode is not yet supported by IPA.
Comment 4 Petr Viktorin 2014-07-09 04:05:42 EDT
Fixed in FreeIPA 4.0.0 (Rawhide/Fedora 21)

Note You need to log in before you can comment on or make changes to this bug.