Bug 1009701 - libvirt not installable in Rawhide: Requires: libwsman_client.so.1()(64bit)
libvirt not installable in Rawhide: Requires: libwsman_client.so.1()(64bit)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2013-09-18 18:24 EDT by Richard W.M. Jones
Modified: 2014-02-03 12:05 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 15:08:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-09-18 18:24:25 EDT
Description of problem:

libvirt is not installable in Rawhide:

DEBUG util.py:266:   --> libvirt-devel-1.1.2-1.fc21.x86_64
DEBUG util.py:266:   --> Already installed : 4:perl-5.18.1-288.fc21.x86_64
DEBUG util.py:266:   --> Already installed : gawk-4.1.0-2.fc20.x86_64
DEBUG util.py:266:  Error: Package: libvirt-client-1.1.2-1.fc21.x86_64 (build)
DEBUG util.py:266:             Requires: libwsman_client.so.1()(64bit)
DEBUG util.py:266:   You could try using --skip-broken to work around the problem
DEBUG util.py:266:   You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):

libvirt-devel 1.1.2-1.fc21
Comment 1 Eric Blake 2013-09-18 18:29:00 EDT
Known issue (thanks libwsman folks for bumping .so without telling us), and will be fixed as part of the CVE builds that we're in the middle of working on.
Comment 2 Cole Robinson 2013-09-23 15:08:46 EDT
Fixed in libvirt-1.1.2-3.fc21
Comment 3 D. Charles Pyle 2014-02-02 19:13:20 EST
This same bug is now happening in Fedora 20.  Yumex (and Yum) gives me the following for the last couple days:

Dependency Resolution Errors:

Package: libvirt-daemon-1.1.3.3-4.fc20.x86_64 (updates-testing)
    Requires: libwsman_client.so.1()(64bit)
    Available: libwsman1-2.3.6-8.fc20.x86_64 (fedora)
        libwsman_client.so.1()(64bit)
    Installed: libwsman1-2.4.3-1.fc20.x86_64 (@updates-testing)
       ~libwsman_client.so.2()(64bit)Package: libvirt-client-1.1.3.3-4.fc20.x86_64 (updates-testing)
    Requires: libwsman_client.so.1()(64bit)
    Available: libwsman1-2.3.6-8.fc20.x86_64 (fedora)
        libwsman_client.so.1()(64bit)
    Installed: libwsman1-2.4.3-1.fc20.x86_64 (@updates-testing)
       ~libwsman_client.so.2()(64bit)
Comment 4 Cole Robinson 2014-02-03 09:54:35 EST
Latest updates-testing should fix it, please see: https://bugzilla.redhat.com/show_bug.cgi?id=1060562
Comment 5 D. Charles Pyle 2014-02-03 12:05:26 EST
Thank you kindly.  I now was able to update libvert with zero problems.

Note You need to log in before you can comment on or make changes to this bug.