Bug 1009723 - RFE: Add information about starting memcached and hot rod servers
RFE: Add information about starting memcached and hot rod servers
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: DR5
: 6.2.0
Assigned To: Rakesh
Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 21:55 EDT by Misha H. Ali
Modified: 2013-11-07 18:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 11:38:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-09-18 21:55:26 EDT
See $SUBJECT

Use ISPN information for reference, for example:

http://infinispan.org/docs/6.0.x/user_guide/user_guide.html#_starting_an_infinispan_memcached_server

http://infinispan.org/docs/6.0.x/user_guide/user_guide.html#_starting_an_infinispan_hot_rod_server

These should be separate topics and with as much detail as required. Refer to downloads section in customer service portal for JDG to see separate packages required for these, if any.



Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 2 Rakesh 2013-09-24 08:50:39 EDT
 Infinispan/JDG Server is a "server container" based on AS/EAP. The server can host multiple endpoints (HotRod, Memcached, REST)
./bin/standalone.sh will bring up the default server configuration which for JDG includes an example endpoint for the three protocols mentioned above
Comment 3 Rakesh 2013-09-24 09:12:40 EDT
Confirmed the following brief steps to start the server in Memcached or HotRod from Tristant:

1. Download the server distribution
2. Unpack it to a local directory
3. Launch it using ./bin/standalone.sh which will bring up the server configuration with the 3 endpoints HotRod, Memcached and REST
4. Start the server
Comment 4 Rakesh 2013-09-25 00:56:25 EDT
Misha: From the steps you outlined, it does not look like there are specific commands to launch Hot Rod or memcached. Is that correct? If so, there is no need to add new topics with how to run those.
Comment 5 Rakesh 2013-09-25 06:11:36 EDT
In addition to step 3, it can also be launched using ./bin/clustered.sh which is starting server using clustered.xml configuration
Comment 6 Rakesh 2013-09-25 06:14:03 EDT
Server is started by ./bin/standalone.sh or ./bin/clustered.sh so no need of step 4
Comment 7 Rakesh 2013-09-25 13:59:17 EDT
Confirmed from JDG SMEs that there is NO specific command to start HotRod or Memcached server. You just start the JDG server and it has all connectors started. 

Misha, you said there is no need to add new topics if there are no specific commands to run Memcached or HotRod. So what next for this bug?
Comment 9 Rakesh 2013-09-26 11:38:52 EDT
Closing bug as the investigation revealed this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.