Bug 1009745 - [ja_JP][Admin Portal] Cluster tab -> Logical Networks subtab -> Manage Networks window -> horizontal scroll-bar added due to column width that is changing dynamically per locale
[ja_JP][Admin Portal] Cluster tab -> Logical Networks subtab -> Manage Networ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Lior Vernia
Meni Yakove
network
: i18n
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-09-19 00:00 EDT by Yuko Katabami
Modified: 2016-02-10 14:47 EST (History)
10 users (show)

See Also:
Fixed In Version: is22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:16:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Truncated column header "Migration Network" in ja-JP (225.58 KB, image/png)
2013-09-19 00:00 EDT, Yuko Katabami
no flags Details
Migration Network is also truncated under Network tab, Clusters sub tab (225.58 KB, image/png)
2013-09-19 03:39 EDT, Yuko Katabami
no flags Details
screen-shot: tool-tip for truncated column header (37.64 KB, image/png)
2013-09-19 16:08 EDT, Einav Cohen
no flags Details
screen-shot: horizontal scroll-bar [ja-JP] (31.43 KB, image/png)
2013-09-19 16:09 EDT, Einav Cohen
no flags Details
screen-shot: different column width (55.29 KB, image/png)
2013-09-19 16:09 EDT, Einav Cohen
no flags Details
Not fixed column headers 'Assign All and Required All' cannot resize (31.39 KB, image/png)
2013-10-11 03:34 EDT, Lijun Li
no flags Details
Fixed Manage Networks dialog (33.94 KB, image/png)
2013-12-02 03:09 EST, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19767 None None None Never
oVirt gerrit 19768 None None None Never
oVirt gerrit 20698 None None None Never

  None (edit)
Description Yuko Katabami 2013-09-19 00:00:16 EDT
Created attachment 799727 [details]
Truncated column header "Migration Network" in ja-JP

Description of problem:
Column header "Migration Network" is truncated.

Version-Release number of selected component (if applicable): 3.3.0-0.22


How reproducible: 100%


Steps to Reproduce:
1. Login to Admin Portal in ja-JP
2. Click Cluster tab
3. Click Logical Networks subtab
4. Click Manage Networks action button

Actual results:
Column header "移行ネットワーク" (Migration Network) is truncated to:
移行ネ

Expected results:
Should be fully visible:
移行ネットワーク

Additional info:
Screenshot is attached.
Comment 1 Yuko Katabami 2013-09-19 03:34:16 EDT
This bug is also present in:
Network tab => Clusters subtab => Manage Network

Attaching screenshot.
Comment 2 Yuko Katabami 2013-09-19 03:39:16 EDT
Created attachment 799763 [details]
Migration Network is also truncated under Network tab, Clusters sub tab
Comment 3 Einav Cohen 2013-09-19 16:08:30 EDT
Created attachment 800130 [details]
screen-shot: tool-tip for truncated column header
Comment 4 Einav Cohen 2013-09-19 16:09:08 EDT
Created attachment 800131 [details]
screen-shot: horizontal scroll-bar [ja-JP]
Comment 5 Einav Cohen 2013-09-19 16:09:36 EDT
Created attachment 800132 [details]
screen-shot: different column width
Comment 6 Einav Cohen 2013-09-19 16:19:42 EDT
there is no problem with column header texts being truncated - we have solved that problem using a tool-tip (see attachment 800130 [details]).

there is another thing that bothers me: It seems that the width of the different columns is not "static" (see attachment 800132 [details], in which you can see that each column gets a different width per locale). 
In addition, due to the fact that the most-right column is being stretched out of the window's boundaries, there is a horizontal scroll-bar that is being added to the dialog (see attachment 800131 [details]).

Need to set statically each column width in pixels, and not allow it to stretch beyond this width (all of the other grids in the application behave like this AFAIK). in case text in a certain locale would be too long for the static column width, we have the tool-tip that displays the full column header text.
Comment 7 Yuko Katabami 2013-09-19 18:35:59 EDT
(In reply to Einav Cohen from comment #6)
> there is no problem with column header texts being truncated - we have
> solved that problem using a tool-tip (see attachment 800130 [details]).
> 
> there is another thing that bothers me: It seems that the width of the
> different columns is not "static" (see attachment 800132 [details], in which
> you can see that each column gets a different width per locale). 
> In addition, due to the fact that the most-right column is being stretched
> out of the window's boundaries, there is a horizontal scroll-bar that is
> being added to the dialog (see attachment 800131 [details]).
> 
> Need to set statically each column width in pixels, and not allow it to
> stretch beyond this width (all of the other grids in the application behave
> like this AFAIK). in case text in a certain locale would be too long for the
> static column width, we have the tool-tip that displays the full column
> header text.

Hi Einav,

I overlooked the horizontal bar - when I move it to the right, all headers in ja-JP are fully visible.
Comment 8 Lior Vernia 2013-10-01 02:32:35 EDT
Einav, you were right about there being something fishy behind the scenes, fixed with help from Vojtech.
Comment 9 Lijun Li 2013-10-11 03:31:44 EDT
Verified it's Not fixed on is18 build: rhevm-3.3.0-0.25.beta1.el6ev.noarch.rpm

Not fixed, column headers 'Assign All and Required All' cannot resize.

Please see the attached screenshot.
Comment 10 Lijun Li 2013-10-11 03:34:50 EDT
Created attachment 810890 [details]
Not fixed column headers 'Assign All and Required All' cannot resize
Comment 11 Lior Vernia 2013-10-20 07:40:20 EDT
Correct, there was some infrastructural issue with checkbox headers in general not being resizeable.
Comment 12 Lijun Li 2013-12-02 03:09:11 EST
Verified it's fixed on latest is25 build.
Column headers can resize now.

Please see the attached screenshot.
Comment 13 Lijun Li 2013-12-02 03:09:44 EST
Created attachment 831470 [details]
Fixed Manage Networks dialog
Comment 14 Itamar Heim 2014-01-21 17:16:02 EST
Closing - RHEV 3.3 Released
Comment 15 Itamar Heim 2014-01-21 17:22:58 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.