Bug 1009751 - huge spike in size of debuginfo-common packages
huge spike in size of debuginfo-common packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 00:29 EDT by Alexandre Oliva
Modified: 2013-10-02 02:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.11.2-301.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:35:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2013-09-19 00:29:34 EDT
Between 3.10 and 3.11, there was a huge spike in the size of the debuginfo-common packages in f20 and f21, but not f19.  The debuginfo-common-i686 packages in f19 were sized at about 45MB, just like the 3.9.0-1 and 3.10.0-1 packages built in the f20 collection.  The 3.11.0-1 package in f20, however, jumped up to more than 950MB; the last few -rc7 packages in f20, that did not include the -debug variants, was at a “mere” 350MB.

I've looked a bit into it, and I noticed that the recent debuginfo-common packages seem to contain all of the vmlinux and *.debug files that are duplicated in the non-common debuginfo packages, in addition to the sources.  The only significant difference between the spec files is that the macro that sets debuginfo_args contains some “+”s in f20 that, in f19, appear as “.”s.  I don't quite understand that change, so I can't tell whether it caused the change, or whether the cause is in rpm or elsewhere in the build machinery.
Comment 1 Alexandre Oliva 2013-09-19 00:48:44 EDT
I was mistaken when I wrote debuginfo-common-i686 contained the data that should have been in all other kernel*debuginfo packages.  It does not contain files that are present in kernel-debuginfo; only the other variants are ending up in the debuginfo-common package.

Another bit I noticed right after posting this: the PAE-debuginfo, debug-debuginfo and PAEdebug-debuginfo packages are nearly empty.  It looks like debuginfo-common is preempting all the variant debuginfo files.

I see dirnames in debuginfo-common match the *i686+PAE* glob pattern in f20, which explains the change to the debuginfo_args pattern.  I guess it the + sign needs more quoting to avoid having it interpreted as 1-or-more of the previous character; perhaps changing \+ to e.g. [+] in the debuginfo_args expression will make the selection regexp work without having to get the amount of quoting just right.
Comment 2 Josh Boyer 2013-09-23 15:06:06 EDT
OK, I'll take a look.  This likely came in with the solution Harald came up with for sorting out the kernel-install issues with variant kernels.  CC'd him as well.
Comment 3 Josh Boyer 2013-09-25 12:45:50 EDT
Thanks for the tip.  Using [] seems to have worked as you suggested.  Here is a scratch build with that change, and the debuginfo RPMs appear correct now.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5977361

I've committed the fix to F20 and master.
Comment 4 Fedora Update System 2013-09-30 12:27:50 EDT
kernel-3.11.2-301.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.2-301.fc20
Comment 5 Fedora Update System 2013-09-30 22:00:20 EDT
Package kernel-3.11.2-301.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.2-301.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17982/kernel-3.11.2-301.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-10-02 02:35:49 EDT
kernel-3.11.2-301.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.