Bug 100976 - rexec is broken ("Invalid argument")
rexec is broken ("Invalid argument")
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: libc (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 06:53 EDT by Ronny Buchmann
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 07:40:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of rexec on shrike (13.85 KB, text/plain)
2003-07-28 06:56 EDT, Ronny Buchmann
no flags Details
strace of rexec on valhalla (18.60 KB, text/plain)
2003-07-28 06:57 EDT, Ronny Buchmann
no flags Details

  None (edit)
Description Ronny Buchmann 2003-07-28 06:53:48 EDT
Description of problem:
rexec fails with "Invalid argument"

Version-Release number of selected component (if applicable):
rsh-0.17-14 (shrike)
rsh-0.17-17.1 (severn)

Results
severn:
[root@vmrh9093 root]# rexec vmrh73 ls
Password:
rexec: Invalid argument

shrike:
[root@akde1030 root]# rexec vmrh73 ls
Password:
rexec: Invalid argument

valhalla:
[root@vmrh73 root]# rexec vmrh73 ls
Password:
anaconda-ks.cfg
install.log
install.log.syslog
rexec.trace.fail
rexec.trace.ok
Comment 1 Ronny Buchmann 2003-07-28 06:56:21 EDT
Created attachment 93186 [details]
strace of rexec on shrike

generated with "strace -o rexec.trace.fail vmrh73 ls"
Comment 2 Ronny Buchmann 2003-07-28 06:57:44 EDT
Created attachment 93187 [details]
strace of rexec on valhalla

generated with "strace -o rexec.trace.ok vmrh73 ls"
Comment 3 Fabio Bettoni 2003-08-12 11:15:41 EDT
I have 2 systems with RH9, glibc-2.3.2-27.9 and rsh updated to 0.17-17.1

The first:
Kernel 2.4.21 SMP compiled by myself on a 4 Pentium 133
IT WORKS !

The second:
Kernel 2.4.20-19.9 NO SMP installed from RPM on a Pentium4 2GHz
invalid argument.

Comment 4 Fabio Bettoni 2003-08-14 03:05:58 EDT
I think problem is in /lib/tls/libc.so.6 -> libc-2.3.2.so

In the first working system I described in the previous message I have the 
following:
# ldd /usr/bin/rexec
        libc.so.6 => /lib/libc.so.6 (0x4001d000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


In the second not working system I have the following:
# ldd /usr/bin/rexec
        libc.so.6 => /lib/tls/libc.so.6 (0x42000000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

i386 version of glibc does not contain /lib/tls as i686 does

I've tried to update to i386 version to check if it works on a i686 system but 
the whole system crashed and i don't know how to resume.



Comment 5 Jakub Jelinek 2004-09-09 07:40:29 EDT
Well, neither RHL7.3 nor RHL9 is supported anymore.
rexec certainly works for me on various distribution versions
and this report lacks all important details.
It very much depends on various configuration files and firewall settings.
If you suspect NTPL libc (I don't see why it would have anything to
do with rexec), you can LD_ASSUME_KERNEL=2.4.1 or LD_ASSUME_KERNEL=2.2.5
to use a different libc version.
If you manage to reproduce this with a supported release and
provide all relevant configuration files so that it can be reproduced,
please reopen.
Comment 6 dricciardi 2005-06-15 12:31:11 EDT
(In reply to comment #5)
> Well, neither RHL7.3 nor RHL9 is supported anymore.
> rexec certainly works for me on various distribution versions
> and this report lacks all important details.
> It very much depends on various configuration files and firewall settings.
> If you suspect NTPL libc (I don't see why it would have anything to
> do with rexec), you can LD_ASSUME_KERNEL=2.4.1 or LD_ASSUME_KERNEL=2.2.5
> to use a different libc version.
> If you manage to reproduce this with a supported release and
> provide all relevant configuration files so that it can be reproduced,
> please reopen.

I had the same error "rexec: Invalid argument" on my 
RedHat9 and FedoraCore3 systems and I downloaded  
rsh-0.17-24 and rsh-server-0.17-24 from fedora-redhat
updates and finally they work on both the systems without 
any other modification. :-)

Note You need to log in before you can comment on or make changes to this bug.