Bug 100978 - Parent content type shown is always the same as the content type name
Parent content type shown is always the same as the content type name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 07:10 EDT by redhatcms
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version: Nightly 29/08
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 05:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhatcms 2003-07-28 07:10:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
From the 'Content Types' tab of the Redhat CMS, when selecting any of the 
predefined content types e.g. Agenda, Event etc, or selecting any new custom 
content types the 'Parent content type' is shown incorrectly.

i.e. if you select the News Item content type its parent is shown as 'News 
Item'. If you create a new custom content type called 'Foo' whose parent 
content type is 'Article', the parent content type is always shown also 
as 'Foo'. When creating new instances of Foo it is clear that 
actually 'Articule is being used as the parent content type.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a new custom content type e.g Test, with a parent content type 
selected e.g. Article.
2.After creating the content type its parent will be shown incorrectly.
3.
    

Actual Results:  The parent content type is shown incorrectlya as 'Test'.

Expected Results:  The parent content type should have been shown as 'Article'.

Additional info:
Comment 1 Richard Li 2003-07-28 08:18:55 EDT
Which nightly are you on? This works correctly on the tip.
Comment 2 redhatcms 2003-07-28 08:57:29 EDT
Thanks for your response.

I'm using the following nightly builds:

ccm-cms-5.3.0.AUTO.07.08.2003-1-bin.zip
ccm-core-5.3.0.AUTO.07.08.2003-1-bin.zip

These were the latest nightly builds I could find. I'll try checking out the 
latest src from CVS and retesting this.

Note that currently the CVS repos appears to be overloaded as I repeatedly 
receive 
"cvs [checkout aborted]: Error reading from server cvs.sourceforge.net: 0 "
using either the hostnames of cvs.ccmdev.sourceforge.net and 
cvs.sourceforge.net. I was finally able to check out the source after a number 
of attempts.

I'll validate the issue is fixed and update the bug accordingly. 
Comment 3 Richard Li 2003-07-28 08:59:49 EDT
Yes, that's pretty old.

We don't maintain the CVS sources; the community does with sourceforge. My
understanding is that SF is having scalability problems due to the enormous
number of projects that they serve.
Comment 4 redhatcms 2003-07-30 09:32:31 EDT
The link http://rhea.redhat.com/faq.html#where-download-ccm directs me to 
either:
a) version 5.0 which is old
b) the nightly builds where the latest appears to be *5.3.0.AUTO.07.08.2003* 
which has the bug described above in it.
c) CVS which has connection issues currently.

Where can I obtain the latest 'tip' code to retest this issue e.g. a nightly 
build from 29th July 2003?
Comment 5 redhatcms 2003-07-31 05:17:38 EDT
Tested and fixed in the nightly build from the 29/8/2003.

Note You need to log in before you can comment on or make changes to this bug.