Bug 10098 - elm specfile Buildroot
elm specfile Buildroot
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: elm (Show other bugs)
6.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-09 15:35 EST by Jeremy Katz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-09 15:51:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2000-03-09 15:35:03 EST
The elm specfile in piglet (also the same in rawhide) uses a Buildroot hard
coded to /var/tmp/%{name}-root.  It makes more sense to use
%{_tmppath}/%{name}-root just so you can have the build root where you
want/need it due to space considerations.
Comment 1 Jeff Johnson 2000-03-09 15:51:59 EST
It ain't just elm that codes a build root that way.

Anyways, the Right Thing To Do is to put
	%_buildroot	%{_tmppath}/%{name}-root
as part of the build system configuration. That will take precedence
over everything but the command line, and just *delete* BuildRoot:
from spec files entirely.

Marking as WONTFIX in the sense CANTFIX because of legacy packaging.

Note You need to log in before you can comment on or make changes to this bug.