Bug 1009806 - RFE: make searching in the list of keyboards possible using English
RFE: make searching in the list of keyboards possible using English
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 03:36 EDT by Mike FABIAN
Modified: 2013-10-07 02:09 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-20.21-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 21:55:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
keyboard-add-dialog-in-anaconda.png (160.74 KB, image/png)
2013-09-19 03:40 EDT, Mike FABIAN
no flags Details
input-source-add-dialog-in-gnome.png (68.03 KB, image/png)
2013-09-19 03:44 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-09-19 03:36:18 EDT
In “gnome-control-center region”, there is the nice feature that one
can search in English always when adding input methods.  I.e. when
running in Japanese for example, one can still type “german” into
the search field to find the German keyboard, which is listed as ドイツ語.

That does not work when selecting keyboard layouts in anaconda.
One can only search for the strings exactly as they are listed,
not for the original English. One can only search for the translated
strings.

Therefore, is quite hard to find the ドイツ語(ドイツ語) keyboard, one
has to scroll through the huge list of layouts to find it. As no
Japanese input method is available at that stage, searching for ドイツ
to find the translation ドイツ語(ドイツ語) is not possible.

Maybe the search could be made to match also if the input matches
the untranslated string so that typing “german” also matches
ドイツ語(ドイツ語), just as it does in “gnome-control-center region”?

See screenshots ...
Comment 1 Mike FABIAN 2013-09-19 03:40:02 EDT
Created attachment 799764 [details]
keyboard-add-dialog-in-anaconda.png

Left: I entered nothing into the search field but scrolled down the list
      until I found ドイツ語(ドイツ語)

Centre: I typed “german” into the search field. It matches some
      entries which happen to contain “German” untranslated, but
      it does not match the “main” German keyboard layout
      ドイツ語(ドイツ語) because this is 100% translated.

Right: Searching for “deutsch” finds nothing (of course ...)
Comment 2 Mike FABIAN 2013-09-19 03:44:19 EDT
Created attachment 799765 [details]
input-source-add-dialog-in-gnome.png

The “add input source” dialog in “gnome-control-center region”.

Left: searching for “german” matches ドイツ語, although the
    translated string contains no “german” anymore, only the
    untranslated string contains “german”

Centre: searching for ドイツ does match ドイツ語, i.e. one can
    of course search for the translated string. But this won’t work
    in anaconda because there is no input method available to type
    ドイツ.

Right: searching for “deutsch” returns nothing (of course ...)
Comment 3 Fedora Update System 2013-09-27 21:15:56 EDT
anaconda-20.21-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.21-1.fc20
Comment 4 Fedora Update System 2013-09-28 21:45:09 EDT
Package anaconda-20.21-1.fc20, pykickstart-1.99.41-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.21-1.fc20 pykickstart-1.99.41-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17921/pykickstart-1.99.41-1.fc20,anaconda-20.21-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-03 21:55:10 EDT
anaconda-20.21-1.fc20, pykickstart-1.99.41-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Mike FABIAN 2013-10-07 02:09:00 EDT
Works in Fedora 20 Beta TC1.

Note You need to log in before you can comment on or make changes to this bug.