Bug 1009809 - KeyError: 'name'
KeyError: 'name'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:c912f893cbabfcf66025dd0ebf8...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 04:03 EDT by Kamil Páral
Modified: 2013-10-10 04:48 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-20.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 12:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (308.91 KB, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: anaconda.log (7.58 KB, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: environ (483 bytes, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: lsblk_output (2.35 KB, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: nmcli_dev_list (4.74 KB, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: program.log (35.88 KB, text/plain)
2013-09-19 04:03 EDT, Kamil Páral
no flags Details
File: storage.log (118.45 KB, text/plain)
2013-09-19 04:04 EDT, Kamil Páral
no flags Details
File: syslog (93.45 KB, text/plain)
2013-09-19 04:04 EDT, Kamil Páral
no flags Details
File: ifcfg.log (479 bytes, text/plain)
2013-09-19 04:04 EDT, Kamil Páral
no flags Details
File: packaging.log (341.38 KB, text/plain)
2013-09-19 04:04 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-09-19 04:03:14 EDT
Description of problem:
I just confirmed my fate, main hub appeared and the error popped up.

Version-Release number of selected component:
anaconda-20.18-1

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/udev.py", line 203, in udev_device_get_name
    name = udev_info["name"]
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1587, in handleUdevDeviceFormat
    name = udev_device_get_name(info)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1704, in updateDeviceFormat
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/image.py", line 196, in opticalInstallMedia
    devicetree.updateDeviceFormat(dev)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 590, in _initialize
    self._cdrom = opticalInstallMedia(self.storage.devicetree)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
KeyError: 'name'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/20-Alpha-RC4/Fedora/x86_64/iso/Fedora-20-Alpha-x86_64-DVD.iso initrd=F20/Alpha-RC4/x86_64/initrd.img BOOT_IMAGE=F20/Alpha-RC4/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha
Comment 1 Kamil Páral 2013-09-19 04:03:22 EDT
Created attachment 799769 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2013-09-19 04:03:27 EDT
Created attachment 799770 [details]
File: anaconda.log
Comment 3 Kamil Páral 2013-09-19 04:03:31 EDT
Created attachment 799771 [details]
File: environ
Comment 4 Kamil Páral 2013-09-19 04:03:36 EDT
Created attachment 799772 [details]
File: lsblk_output
Comment 5 Kamil Páral 2013-09-19 04:03:42 EDT
Created attachment 799773 [details]
File: nmcli_dev_list
Comment 6 Kamil Páral 2013-09-19 04:03:51 EDT
Created attachment 799774 [details]
File: os_info
Comment 7 Kamil Páral 2013-09-19 04:03:56 EDT
Created attachment 799775 [details]
File: program.log
Comment 8 Kamil Páral 2013-09-19 04:04:02 EDT
Created attachment 799776 [details]
File: storage.log
Comment 9 Kamil Páral 2013-09-19 04:04:07 EDT
Created attachment 799777 [details]
File: syslog
Comment 10 Kamil Páral 2013-09-19 04:04:10 EDT
Created attachment 799778 [details]
File: ifcfg.log
Comment 11 Kamil Páral 2013-09-19 04:04:15 EDT
Created attachment 799779 [details]
File: packaging.log
Comment 12 Kamil Páral 2013-09-19 04:07:58 EDT
Reproducing bug 1009809. This is a pxebooted installation with inst.repo=nfsiso. Another boot, another crash.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/20-Alpha-RC4/Fedora/x86_64/iso/Fedora-20-Alpha-x86_64-DVD.iso initrd=F20/Alpha-RC4/x86_64/initrd.img BOOT_IMAGE=F20/Alpha-RC4/x86_64/vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1
product:        Fedora
reason:         KeyError: 'name'
release:        Cannot get release name.
version:        20-Alpha
Comment 13 Kamil Páral 2013-09-19 04:18:55 EDT
When I used inst.repo=http://, everything worked OK. This seems to be a problem just with nfsiso (and maybe nfs) source. Proposing as Beta blocker:

When using the dedicated installer images, the installer must be able to use HTTP, FTP and NFS repositories as package sources. 
https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Remote_package_sources
Comment 14 Vratislav Podzimek 2013-09-23 15:19:41 EDT
David, your commit 3178924f1dd1f031579842dd1cb2b9a0e4c5a842 fixing a different bug causes, that blivet is trying to get udev info for an ISO (iso9660) mounted from NFS. I'm not sure how this should be resolved.
Comment 15 Fedora Update System 2013-09-25 12:03:23 EDT
anaconda-20.20-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.20-1.fc20
Comment 16 Mike Ruckman 2013-09-25 12:54:22 EDT
Discussed this in 2013-09-25 Blocker Review Meeting [1]. While this could be a blocker, it isn't clear if nfs repos are working yet and only one is required to work for beta. Will revisit when we have more data on nfs repos.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
Comment 17 Fedora Update System 2013-09-26 20:31:30 EDT
Package anaconda-20.20-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.20-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17681/anaconda-20.20-1.fc20
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-09-27 21:16:32 EDT
anaconda-20.21-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.21-1.fc20
Comment 19 Kamil Páral 2013-10-02 13:40:46 EDT
(In reply to Mike Ruckman from comment #16)
> Discussed this in 2013-09-25 Blocker Review Meeting [1]. While this could be
> a blocker, it isn't clear if nfs repos are working yet and only one is
> required to work for beta. Will revisit when we have more data on nfs repos.
> 
> [1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/

I tested with F20 Alpha and inst.repo=nfs: doesn't seem to be affected.
Comment 20 Mike Ruckman 2013-10-02 15:31:43 EDT
Discussed this in the 2013-10-02 Blocker Review Meeting [1]. This still needs testing to see if at least 1 of nfs/nfsiso works - will revisit once that testing has been done.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-02/
Comment 21 Kamil Páral 2013-10-03 04:29:29 EDT
See comment 19 :-)
Comment 22 Christopher Archer 2013-10-04 00:13:11 EDT
Attempted install without DVD (from attached hard drive)

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/vmlinuz-f20-alpha repo=hd:/dev/sdc2:/Fedora/F20-DVD/
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.i686
package:        anaconda-20.18-1
product:        Fedora
reason:         KeyError: 'name'
release:        Cannot get release name.
version:        20-Alpha
Comment 23 Kamil Páral 2013-10-09 12:11:37 EDT
I have verified that this is fixed with F20 Beta TC1.
Comment 24 Mike Ruckman 2013-10-09 16:50:47 EDT
Discussed this in 2013-10-09 Blocker Review Meeting [1]. This has been voted a RejectedBlocker. As stated in the F20 beta criteria, only one of [nfs, nfsiso] is required to work for beta. As nfs package sources have been confirmed to work, this is rejected as a release blocking bug for f20 beta.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-09/

Note You need to log in before you can comment on or make changes to this bug.