Bug 1009824 - [HHH-8522] CompositeIdTypeBindingTest.testCompositeTypeBinding fails on sybase157
[HHH-8522] CompositeIdTypeBindingTest.testCompositeTypeBinding fails on sybas...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: EAP 6.2.0
Assigned To: Brett Meyer
Zbyněk Roubalík
Russell Dickenson
:
Depends On:
Blocks: 1010467
  Show dependency treegraph
 
Reported: 2013-09-19 04:49 EDT by Martin Simka
Modified: 2015-09-01 00:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:13:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simka 2013-09-19 04:49:38 EDT
org.hibernate.test.subselect.CompositeIdTypeBindingTest.testCompositeTypeBinding

Stacktrace

org.hibernate.exception.GenericJDBCException: could not extract ResultSet
	at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:54)
	at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:125)
	at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:110)
	at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.extract(ResultSetReturnImpl.java:61)
	at org.hibernate.loader.Loader.getResultSet(Loader.java:2040)
	at org.hibernate.loader.Loader.executeQueryStatement(Loader.java:1837)
	at org.hibernate.loader.Loader.executeQueryStatement(Loader.java:1816)
	at org.hibernate.loader.Loader.doQuery(Loader.java:900)
	at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:342)
	at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:312)
	at org.hibernate.loader.Loader.loadCollectionSubselect(Loader.java:2305)
	at org.hibernate.loader.collection.SubselectCollectionLoader.initialize(SubselectCollectionLoader.java:81)
	at org.hibernate.persister.collection.AbstractCollectionPersister.initialize(AbstractCollectionPersister.java:674)
	at org.hibernate.event.internal.DefaultInitializeCollectionEventListener.onInitializeCollection(DefaultInitializeCollectionEventListener.java:85)
	at org.hibernate.internal.SessionImpl.initializeCollection(SessionImpl.java:1849)
	at org.hibernate.collection.internal.AbstractPersistentCollection$4.doWork(AbstractPersistentCollection.java:549)
	at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:234)
	at org.hibernate.collection.internal.AbstractPersistentCollection.initialize(AbstractPersistentCollection.java:545)
	at org.hibernate.collection.internal.AbstractPersistentCollection.read(AbstractPersistentCollection.java:124)
	at org.hibernate.collection.internal.AbstractPersistentCollection$1.doWork(AbstractPersistentCollection.java:153)
	at org.hibernate.collection.internal.AbstractPersistentCollection$1.doWork(AbstractPersistentCollection.java:138)
	at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:234)
	at org.hibernate.collection.internal.AbstractPersistentCollection.readSize(AbstractPersistentCollection.java:137)
	at org.hibernate.collection.internal.PersistentBag.size(PersistentBag.java:242)
	at org.hibernate.test.subselect.CompositeIdTypeBindingTest.testCompositeTypeBinding(CompositeIdTypeBindingTest.java:90)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
	at org.hibernate.testing.junit4.ExtendedFrameworkMethod.invokeExplosively(ExtendedFrameworkMethod.java:63)
	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:30)
	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:62)
Caused by: java.sql.SQLException: Incorrect syntax near the keyword 'in'.

	at com.sybase.jdbc4.jdbc.SybConnection.getAllExceptions(SybConnection.java:2780)
	at com.sybase.jdbc4.jdbc.SybStatement.handleSQLE(SybStatement.java:2665)
	at com.sybase.jdbc4.jdbc.SybStatement.nextResult(SybStatement.java:295)
	at com.sybase.jdbc4.jdbc.SybStatement.nextResult(SybStatement.java:272)
	at com.sybase.jdbc4.jdbc.SybStatement.queryLoop(SybStatement.java:2409)
	at com.sybase.jdbc4.jdbc.SybStatement.executeQuery(SybStatement.java:2395)
	at com.sybase.jdbc4.jdbc.SybPreparedStatement.executeQuery(SybPreparedStatement.java:258)
	at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.extract(ResultSetReturnImpl.java:56)
	... 33 more

https://hibernate.atlassian.net/browse/HHH-8522
probably related to
https://hibernate.atlassian.net/browse/HHH-8312
Comment 1 Brett Meyer 2013-09-19 12:46:14 EDT
Test only fix -- Sybase does not support multiple columns in the where clause of a "where in".  Corrected up stream, but should be deferred until EAP 6.3.0.
Comment 2 Brett Meyer 2013-09-25 11:54:20 EDT
Actually, this will go into EAP 6.2.0 ER4's upgrade to Hibernate ORM 4.2.6.Final in 1010467.
Comment 6 Martin Simka 2013-10-11 08:57:03 EDT
verified on EAP 6.2.0.ER5

Note You need to log in before you can comment on or make changes to this bug.