Bug 1009840 - bacula / Director does not respect "Action On Purge = Truncate"
bacula / Director does not respect "Action On Purge = Truncate"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula (Show other bugs)
6.6
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Josef Ridky
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 05:41 EDT by Miguel Santos
Modified: 2017-09-25 04:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-25 04:28:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Standard configuration files, with Action On Purge added to the director configuration. (1.93 KB, application/x-bzip-compressed-tar)
2013-09-19 05:43 EDT, Miguel Santos
no flags Details

  None (edit)
Description Miguel Santos 2013-09-19 05:41:22 EDT
Description of problem:

Bacula does not respect the attribute Action On Purge = Truncate specified in the pool definition of the Director configuration.

Version-Release number of selected component (if applicable):
5.0.0-12

How reproducible:
Base installation of bacula-director, bacula-storage and bacula-client. Set "Action On Purge = Truncate" on the pool definition of the director daemon.


Steps to Reproduce:
1.- Create a basic configuration where we can backup to file system. See attached configuration files.
2.- Specify on the Pool definition the attribute "Action On Purge = Truncate"
3.- Manually purge a volume
 # bconsole
 * purge
 * 3
 * (select the pool)
 * (select the media)

Actual results:
The record is marked as purged but the file is not truncated.

Expected results:
The record is marked as purged but the file should be truncated.

Additional info:
Comment 1 Miguel Santos 2013-09-19 05:43:04 EDT
Created attachment 799807 [details]
Standard configuration files, with Action On Purge added to the director configuration.
Comment 3 RHEL Product and Program Management 2013-10-13 19:09:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Josef Ridky 2017-09-25 04:28:17 EDT
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the
Production 3 Phase, Critical impact Security Advisories (RHSAs) and
selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as
they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase
and will be marked as CLOSED/WONTFIX. If this remains a critical
requirement, please contact Red Hat Customer Support to request
a re-evaluation of the issue, citing a clear business justification. Note
that a strong business justification will be required for re-evaluation.
Red Hat Customer Support can be contacted via the Red Hat Customer Portal
at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.