Bug 1009846 - Read-only Java Editor allows changes but not saving
Read-only Java Editor allows changes but not saving
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: Jan
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 05:54 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-09-19 05:54:48 EDT
Description of problem:
The new Java Editor has several interconnected issues. The main being that it allows you to change a file but not save these changes.

If it is supposed to be read-only as per bug 1001561 comment 1, it should not allow users to even make any changes. In that case, Java Editor is a bit of a misnomer (since no editing can/should be done). 
Also, the 'editor' pane is in a tab (see at the bottom of the 'editor') called Edit - using the Source tab that is present in many other editors would be better for this read-only 'editor'.

Either keep the java code editable and allow users to save the changes made, or really make it read-only.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3
Comment 1 Jan 2013-09-20 12:20:04 EDT
The java editor has been changed to conform it to other source editors that are already in use throughout the  platform.

master: https://github.com/droolsjbpm/kie-wb-common/commit/17e68c43e911ebeeddcb72d9f25034b1412f576d

6.0.x: https://github.com/droolsjbpm/kie-wb-common/commit/d51c30844e198245913674bb323dd9a1a7dff88e
Comment 2 Zuzana Krejčová 2013-10-21 03:42:02 EDT
Verified on ER4 - java source files now open in source view, non-editable.

Note You need to log in before you can comment on or make changes to this bug.