Bug 1009862 - NPE on repository shutdown if monitoring isn't enabled
NPE on repository shutdown if monitoring isn't enabled
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Horia Chiorean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 06:39 EDT by Horia Chiorean
Modified: 2013-10-24 05:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 03:49:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2049 Blocker Closed NPE on repository shutdown if monitoring is not enabled 2013-10-24 05:19:10 EDT

  None (edit)
Description Horia Chiorean 2013-09-19 06:39:01 EDT
When a repository that doesn't have monitoring enabled is shutdown, a NPE is raised.
Comment 1 Horia Chiorean 2013-09-20 03:49:55 EDT
It turns out the MBean that is responsible for the crash is a feature that is only present in the community codebase, so it doesn't affect the product code.
Comment 2 JBoss JIRA Server 2013-09-20 03:50:58 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2049

Fixed repository shutdown when monitoring is not enabled
Comment 4 JBoss JIRA Server 2013-09-20 06:07:13 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2049

Merged into the 'master' branch.
Comment 5 JBoss JIRA Server 2013-10-24 05:19:10 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2049 to Closed

Note You need to log in before you can comment on or make changes to this bug.