Bug 1009876 - CLI - "distributor subscribe" shows error "Couldn't find system ''"
CLI - "distributor subscribe" shows error "Couldn't find system ''"
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2013-09-19 07:55 EDT by Hayk Hovsepyan
Modified: 2017-06-26 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 16:36:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-09-19 07:55:53 EDT
Description of problem:
Several CLI commands on "distributor" shows error "Couldn't find system ''".
List of commands:
"distributor unsubscribe"
"distributor subscribe"
"distributor subscriptions"

Version-Release number of selected component (if applicable):
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-common-1.4.3-14.el6sam_splice.noarch
katello-headpin-1.4.3-14.el6sam_splice.noarch
candlepin-selinux-0.8.26-1.el6sam.noarch
thumbslug-0.0.34-1.el6sam.noarch
candlepin-cert-consumer-dionysus.usersys.redhat.com-1.0-1.noarch
openldap-2.4.23-31.el6.x86_64
Katello-Katello-Installation-SAMLatest-1.0-10.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-candlepin-cert-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-50.noarch
katello-configure-1.4.4-4.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-candlepin-1.4.3-14.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-0.8.26-1.el6sam.noarch
thumbslug-selinux-0.0.34-1.el6sam.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-11.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-glue-elasticsearch-1.4.3-14.el6sam_splice.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-tomcat6-0.8.26-1.el6sam.noarch
katello-headpin-all-1.4.3-14.el6sam_splice.noarch
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
katello-cli-1.4.3-11.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

How reproducible:
always

Steps to Reproduce:
1. Create distributor.
2. Try to execute some CLI commands for distributor to subscribe/unsubscribe to pool or list the subscriptions. Error will be shown.

Actual results:
error is shown in "distributor" CLI commands

Expected results:
no error should be there

Additional info:
on UI it works fine
Comment 1 Bryan Kearney 2017-06-26 16:36:56 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.